2 Replies Latest reply on Apr 1, 2016 5:41 PM by la_karli

    How to install Python 2.7.9+?


      Hey guys, I have recently been playing around with AWS IoT and I would like to do some test with python on the Edison using paho-mqtt.  In order to connect to AWS IoT I need to use ssl.PROTOCOL_TLSv1_2.


      Unfortunately that version of TLS is not included in the SSL package below Python Version 2.7.9.


      Any suggestions on getting 2.7.9 (or better yet 2.7.11) set up on the edison?  I see that currently only Python-Core 2.7.3 is in the opkg repos.


      (Running Edison 159.devkit)


      Thanks so much!