4 Replies Latest reply on Dec 28, 2015 11:50 AM by allan_intel

    Intel NUC DN2820FYKH "Reboot and select proper boot device" message after trying to boot OS install from USB

    AppleII

      Dear Intel community,

       

      I am an happy owner of a NUC Intel NUC DN2820FYKH, yesterday I started playing around with various OS. I had before Ubuntu + Kodi on startup. Then I formatted and installed Kodibuntu. Then, I wanted to install Openelec. I stopped there, because various messages started to appear while I was booting from the USB, now it appears on a black screen:

       

      "Reboot and select proper boot device"

       

      I made the USB with my Mac using Unetbootin. Before yesterday, I successfully installed Ubuntu, Kodibuntu with USBs (2.0 or 3.0) made with my MacBook (El Capitan) both with the front USB or the back USBs, without success. Seems that something went wrong with the bios after inserting the Openelec USB, because before this attempt there weren't problem with the boot from USB. Tried UEFI, Legacy, both. Tried bios update, bios downgrade, bios reset, bios reset with F9, bios reset by moving the PIN from the motherboard (strange here that if I move the pin from 1-2 to 2-3 and I boot, it doesn't go to the recovery bios mode, but directly boots from SSD the current OS, which is Kodibuntu, the latest one I managed to install before this issue).

       

      Right now I can use Kodibuntu, but I can't format nor install any new OS. Very annoying.