6 Replies Latest reply on Dec 30, 2015 6:46 AM by kilter

    No Mount After failed flash, Is my board bricked? I think I've tried everything

    dewar

      I recently tried to flash my Edison board using the flashall script method on the mac for the newest Yocto image but after the reboot it timed out because it could no longer be detected/mounted. Strangely enough I can still get to the serial terminal. I think I have literally tried everything at this point and still can't get it to work I was hoping someone could point me in the right direction on some things I haven't tried or can figure out the issue.


      USB

      I tried 5 different cables and they all seemed to work meaning I can access the serial terminal through all of them. Definitely don't think this is the issue. I have also flipped the switch to the lowest position.

       

      PowerSource

      Using the wall plugin

       

       

      Serial Terminal

      When I login to root of the serial terminal I always get this error :

       

       

      Poky (Yocto Project Reference Distro) 1.6 dewar ttyMFD2

       

      Dewar login:  root

       

      [  786.294431] systemd-fsck[7798]: fsck.ext2: Bad magic number in super-block while trying to open /dev/mmcblk0p10

      [  786.296969] systemd-fsck[7798]: /dev/mmcblk0p10:

      [  786.298982] systemd-fsck[7798]: The superblock could not be read or does not describe a correct ext2

      [  786.301585] systemd-fsck[7798]: filesystem.  If the device is valid and it really contains an ext2

      [  786.304409] systemd-fsck[7798]: filesystem (and not swap or ufs or something else), then the superblock

      [  786.307226] systemd-fsck[7798]: is corrupt, and you might try running e2fsck with an alternate superblock:

      [  786.310168] systemd-fsck[7798]: e2fsck -b 8193 <device>

      No directory, logging in with HOME=/

       

      Tried this method:

      boot > run do_ota

      ** Unrecognized filesystem type **

      Saving Environment to MMC...

      Writing to redundant MMC(0)... done

       

      .VVBD.0000000c

       

      microkernel built 11:24:08 Feb  5 2015

       

      ******* PSH loader *******

       

       

      Also tried

       

      boot > run do_flash

      Saving Environment to MMC...

      Writing to MMC(0)... done

      GADGET DRIVER: usb_dnl_dfu

      **freezes here

       

      from the do_flash I tried these below in conjunction

       

      Flashall.sh << cannot detect fails and times out

       

      Flashall.sh --recovery << Tried this on my linux comp and get 20x Intel SoC Detection Failed : Attempt  up to 20 times

      Flash tool lite << cannot detect fails and times out

       

       

      I just don't get it because if I can login to the root serial terminal shouldn't I be able to flash the image??? I've tried this on Windows 7, Linux 32bit-Ubuntu 14.04 and Mac OSX 10, is my board broken?