2 Replies Latest reply on Dec 16, 2015 10:45 AM by orjan

    Edison not booting after firmware upgrade

    orjan

      Hi, I just upgraded the Yocto firmware to edison-image-ww25.5-15, by extracting the image, copying all the files into the Edison USB storage, logged in to Edison via the serial post and entered the command "reboot ota". After that, Edison seem to be getting an error "MMC: block number 0x7842843a exceeds max(0x748000)" while booting, and try to boot over and over gain. This is the repeating output I get:

       

      ******************************

      PSH KERNEL VERSION: b0182727

                      WR: 20104000

      ******************************

       

      SCU IPC: 0x800000d0  0xfffce92c

       

      PSH miaHOB version: TNG.B0.VVBD.0000000c

       

      microkernel built 23:15:13 Apr 24 2014

       

      ******* PSH loader *******

      PCM page cache size = 192 KB

      Cache Constraint = 0 Pages

      Arming IPC driver ..

      Adding page store pool ..

      PagestoreAddr(IMR Start Address) = 0x04899000

      pageStoreSize(IMR Size)          = 0x00080000

       

      *** Ready to receive application ***

       

       

      U-Boot 2014.04 (Aug 20 2014 - 16:08:32)

       

            Watchdog enabled

      DRAM:  980.6 MiB

      MMC:  tangier_sdhci: 0

      In:    serial

      Out:  serial

      Err:  serial

      Hit any key to stop autoboot:  0

      Target:blank

      Partitioning already done...

      reading ota_update.scr

      MMC: block number 0x7842843a exceeds max(0x748000)

       

      I stop autoboot and did "run do_ota" ad the boot prompt, but I get the same error "reading ota_update.scr MMC: block number 0x7842843a exceeds max(0x748000)". I tried to flash Edison with ./flushall.sh, but it doesn't recognize the board and times out, since the board is not booting. Of the same reason Edison does not show up as an USB storage anymore.

       

      Before upgrading, I had not problem, everything worked as it should. I'm using an older HP ElitBook 8440p with Ubuntu 10.04 for this project.

       

      The reason I choose to upgrade to edison-image-ww25.5-15 (2.0) and not to the latest edison-iotdk-image-280915 (2.1) is that the later it too big (1Gb) to fit in the Edison USB storage (0.8Gb).


      I would be very grateful if someone can give med some advice on how to proceed with this. I hope the device is not beyond rescue.