8 Replies Latest reply on Dec 23, 2015 4:02 AM by G0DHAND

    3 beeps after bios downgrade

    G0DHAND

      Hey guys. I need some help. I'm running a

      Intel dh61ww motherboard

      Core i7 3770 3.4 ghz

      8gb memory(4gb x2)

      Geforce gt 420

       

      I've had this setup for more than a year now.

       

      I've noticed that my bios version is 38 and wanted to update it to the latest 120. But everytime I've tried updating it to 48, it fails. I've read somewhere that there was a problem with ver 38 so I've tried downgrading it to 35 first before upgrading to 48 so as to bypass 38. But after downgrading. My pc won't boot. There were 3 beeps,no led lights and no signal to the monitor. I've tried removing the cmos battery, I've tried cleaning then inserting and reinserting my RAM one at a time in different socket combinations. I've tried removing my videocard. I've tried unplugging and replugging the cables connected to my mobo. I've tried removing the bios jumper. I've tried using a flash drive bios recovery of version 35. But still the problem persists.

      Is there still a way to fix my computer? Thanks