1 Reply Latest reply on Dec 12, 2015 7:11 AM by v665f6atu3

    SRT on Windows 10, iastor.sys not used

    v665f6atu3

      Hi,

       

      i've recently upgraded to Windows 10 Pro x64 and to a X99-based platform, from Windows 7 and a Z77. However, i can not enable SRT in the RST interface, as Windows refuses to use the proper iastor.sys driver and defaults to the Microsoft one.

      I've tried everything within my power to make Windows use Intel's driver, including countless reinstalls of RST and trying to manually install the Intel driver through the inf files. The cached and cache drives are connected to the proper SATA ports 1-6, while the system drive is plugged into a port in the 7-10 range.

       

      I've read somewhere that the iastor.sys driver was still unstable on Windows 10, so Intel supposedly pulled it last minute. Is this true?

      If not, how else could i get Windows to use the proper driver?

       

      Thanks!

       

      System:

      Asus X99-A

      Intel 5960X

      Nvidia GTX 970

      32GB DDR4-2400

      Crucial MX100 512GB (system drive)

      Samsung 830 128GB (intended cache drive)

      3x 3TB Intel Raid 5

        • 1. Re: SRT on Windows 10, iastor.sys not used
          v665f6atu3

          Completely erasing the partition layout on the disk did the trick!

          You might read that you need exactly one partition with the hibernate flag set or other myths, but in my case, completely clearing the SSD is the only thing that worked.

           

          My system is still not using the iastor driver, but it seems like the Microsoft one enables the same functionality when the rest of the system is configured exactly right.

           

          -Solved-