9 Replies Latest reply on Dec 31, 2015 10:47 AM by Intel_Alvarado

    Disable u-boot console

    egorf

      Hello!

       

      Is there way to disable u-boot console on ttyMFD2 UART at startup or at least skip the "press any key to stop autoboot" part? Preferrably inside the yocto image.
      When a peripheral is connected, it stops Edison from booting...

       

      Thank you!

        • 1. Re: Disable u-boot console
          Intel_Alvarado

          Hi,

           

          When you say “skip the "press any key to stop autoboot" part” you mean you want the Edison to boot faster so you don’t need to wait until it finishes booting? Or, is it just a matter of the console not showing the boot log?

           

          What peripheral are you connecting, do you had it connected before powering the Edison or you connect it while the Edison is booting? Do you see any booting warning or error? How are you powering the Edison? What image version are you using?

           

          Sergio

          • 2. Re: Disable u-boot console
            Vincenze

            Do you see the '@' sign, then the Edison reboots?

            Do you have the mini breakout board?

             

            The mini breakout board works unreliably when it gets power from a USB port.

             

            When the Edison boots up, I see a splash of current up to 0.15A, then it settles down to 0.04A.

            If the Edison doesn't get enough power, it reboots.

             

            Older USB ports can provide only 0.1A, but newer ones 0.5A, and USB3 0.9A.

            I think the power circuit on the breakout board should be able to supply up to 0.19A when powered from a USB port.

             

            You should try an external power supply.

            • 3. Re: Disable u-boot console
              egorf

              Hello!

               

              I am using a custom yocto image based on the latest released sources.

               

              The peripheral is a UART connected radio. Edison's powering doesn't seem to be the problem as it all works fine after booting. The problem only occurs during the boot process.

               

              As I see the problem, if the radio is connected and receives data while Edison's is booting, it stops u-boot from autobooting the kernel during this "Press any key to stop autoboot" sequence.

               

              I turned this feature off by adding

               

              bootdelay=0
              

               

              to edison-src/meta-intel-edison/meta-intel-edison-bsp/recipes-bsp/u-boot/files/edison.env

               

              However, I did not have chance to test it yet, but the feature is turned off now.

               

              I have a different question though, how do I silence the console output at the startup?

               

              I tried adding defines from this article to the "upstream_to_edison.patch"  in the "edison.h" part of the patch but that did not help.

               

              Any help is highly appreciated!

              • 4. Re: Disable u-boot console
                Vincenze

                Doesn't your radio chip have the SHUTDOWN pin? Do you use a level translator with the same shutdown pin? You can pull it down to the ground via a resistor during the boot process and then pull it up via a GPIO pin.

                 

                Well, the consumption of the Edison is 4 times higher during booting.

                • 5. Re: Disable u-boot console
                  CMata_Intel

                  Hi egorf,

                   

                  Did you try with Vincenze’s suggestions? Any updates/improvements on this?

                  Have you tried with environment variables?

                   

                  Regards,

                  Charlie

                  • 6. Re: Disable u-boot console
                    egorf

                    Hello CMata_Intel,

                     

                    I did not actually. The thing with this solution is that it will only help with one exact situation, and I'm trying to fix this on a bigger level.

                    The thing is tied to u-boot console, which is started to ttyMFD2 UART port and interrupts the kernel boot process. One thing I did was setting bootdelay variable to 0 in the Yocto image sources("blankcdc.env" target seems to be the one that needs to be changed). But that stops you from reflashing the device as the variable seems to be global in terms of intefaces sets 0 bootdelay on USB port as well. To save the device you can change bootdelay from Linux via `fw_setenv` command and reflash again, but that is not a solution to the problem.

                     

                    What I see as a solution is to disable the serial console on UART completely.

                    U-boot docs do not suggest a way to disable the console(only the output) and the only thing I found is some patches in their mailing list.

                     

                    I actually wish you could help me with this situation

                     

                    Thanks!

                    • 7. Re: Disable u-boot console
                      Intel_Alvarado

                      Are you looking for something like this Re: How to enable usage of serial port /dev/ttyMFD2 ? The goal of this user was to disable console access in ttyMFD2. There are several suggestions you might find useful.

                       

                      Sergio

                      • 8. Re: Disable u-boot console
                        egorf

                        Nope, this is about the kernel console. U-boot runs before the kernel and, in fact, loads it

                        • 9. Re: Disable u-boot console
                          Intel_Alvarado

                          Hi,

                           

                          Have you made any progress in disabling the console in uboot? I haven’t done this on the Edison however I found some links that might be useful to you.

                          Look at:

                          https://blackfin.uclinux.org/doku.php?id=silent_booting

                          https://wiki.openwrt.org/doc/techref/bootloader/uboot.config

                          Disabling Serial Port Debug Console (Linux/U-Boot)

                          http://stackoverflow.com/questions/22143253/why-doesnt-u-boot-disable-the-console-output

                           

                          Sergio