1 Reply Latest reply on Dec 9, 2015 1:57 PM by jonathan_intel

    Intel 750 firmware upgrade made it unable to enter UEFI config

    Johnytec

      In short:

      Intel 750 400GB, GPT partitioned, in PCI-E 16x on Asrock Z77 Extreme-4.

      Worked fine before. After firmware upgrade, cannot get into UEFI settings, but no problem with OS loading. Firmware version: 8EV10174

      Click DEL or F2, it'll hang up at a blank screen with only "A9" shown. Need to reset to restart.

      Unplug 750, can get into UEFI config without any problem.

      Plug 750 back, hang up at "A9", cannot get into UEFI config.

      Please show me how to downgrade firmware.

       

       

      In detail:

      I've been using Intel 750 400GB, GPT partitioned, on an old mainboard, Asrock Z77 Extreme-4, utilizing the main PCI-E 16x channel. Configuration is Intel i5-3470/24GB DDR3/Intel 750+Intel 330 180GB+Seagate 3TB drive *2. System is Windows 10 Enterprise x64 on UEFI firmware. Firmware version: 8EV10174.

       

      The kindhearted Asrock engineers released a beta bios update back in June to support NVMe, which allowed me to use 750 on this old mainboard without any problem for 3 months now. Last week, I updated Intel SSD Toolbox to 3.3.3, and it prompted me of a firmware update for Intel 750. I always trust Intel's firmware quality, which I regret now, so I clicked okay. It went on well and the system was as good as before. However, when I wanted to enter UEFI configuration to adjust fan speed today, to my surprise, I cannot enter the UEFI config anymore. Right now when I power on the computer, press del or F2, it'll hang up all black with only "9a" shown on it, and I need to hit the reset button to restart the computer to get rid of that screen. If I don't hit reset, it'll hang there for as long as you allow it. Of course, if I just let it load the Windows system, it'll work fine. I can get into my system and everything is working normally, but the problem is I need to get into UEFI settings, which should perfectly work.

       

      I googled this "9a UEFI error" for a while and it appears to be a problem with peripheral. Odd thing is I hadn't changed anything these days and even if I unplugged all my USB connectors, leaving only the keyboard, it still hang up at "9a". I opened the case, and found the embedded debugger shows "9A" as well. All I did in recent two weeks was a firmware update for 750, so I assumed that was the culprit. To prove it, I unplugged it from the mainboard, and the boot into UEFI config was okay. No more "9a" and it went directly into the UEFI settings. Plugged 750 back and it hang up at "9a" again. I've attached the info file from Intel Toolbox.

       

      Now, without further fuss on how disappointed I am with Intel's firmware and testing team, I want to know if there is any way for me to downgrade the firmware for 750. It worked without any problem under the stock firmware and I want that back. If not, please tell me you're gonna fix this problem in the next firmware and release it before the holidays.

       

      Many thanks.