1 Reply Latest reply on Dec 11, 2015 8:42 AM by mikec_intel

    NUC5i7RYH UEFI boot menu entries garbled

    Janos

      I am using NUC5i7RYH with lates (0352) BIOS.

       

      Adding a single boot menu entry with efibootmgr (0.11.0) works fine, e.g. name is displayed correctly in BIOS and can boot it, but adding additional entries do not work as expected.

      I am using this command to add entries:

      $ efibootmgr -v -c -l '\EFI\path\to\foobar.efi' -L 'FooBar'


      Currently my entries are shown as:

      $ efibootmgr -v

      BootCurrent: 0001

      Timeout: 2 seconds

      BootOrder: 0001,0003,0000,0000,0000,0000,0000

      Boot0000* Shell Vendor(xxxxxxxx-xxxx-xxx-xxxx-xxxxxxxxxxxx,)

      Boot0001* Grub HD(1,800,100000,yyyyyyyy-yyyy-yyyy-yyyy-yyyyyyyyyyyy)File(\EFI\debian\grubx64.efi)

      Boot0003* Shell signed Vendor(xxxxxxxx-xxxx-xxx-xxxx-xxxxxxxxxxxx,)

       

      Before rebooting all entries look like Boot0001 and seem okay. After rebooting all but the entry I added first change to Vendor(xxxx,).

      In the BIOS boot menu only Grub shows up.

       

      I've tried removing all entries and adding them again but I get the same result.

       

      Please advise.

       

      Thanks