3 Replies Latest reply on Dec 10, 2015 2:43 PM by jonathan_intel

    Wifi low speed connection (Intel Centrino Wireless-N 2230)

    hedmah

      Hi   
      I have an ASUS laptop S550cm with "Intel Centrino Wireless-N 2230" running W10. Just a few days ago I started to recognize that that my Wi-Fi connection was very low. I compared the connections to another laptop at home (it has the same Wi-Fi card, but run W7) which shows a speed of 130 Mbit/s while my computer shows a speed of 6-13 Mbit/s. I've tried several methods like update drivers, uninstall old drivers, fix power settings, shut down all other Wi-Fi connections in the house and some more methods. But with no success.

      Does anyone know how I could solve the problem?

        • 1. Re: Wifi low speed connection (Intel Centrino Wireless-N 2230)
          jonathan_intel

          Hello hedmah,

           

          Here are some additional recommendations and relevant aspects regarding slow WiFi connections:

           

          - Disable the Bluetooth adapter in you PC and check if this helps. This is normally done with a switch in the computer chassis, or with a key combination; it may also be done from Windows® configuration.

           

          - Apply the configuration from the advisory: Wireless Networking — What are the Recommended Settings for 802.11n Connectivity?

           

          If the issue persists, try doing a clean install of the Wireless driver:

           

          1. There are no drivers for the Intel® Centrino® Wireless-N 2230 specific for Microsoft Windows 10®, however, it should work fine using the drivers for Windows 8.1®. Obtain the WiFi drivers from the Computer Manufacturer Support, as second option you can obtain the generic version: Download Intel® PROSet/Wireless Software for Windows 8.1*.
          2. Go to Control Panel - Programs and Features and Uninstall "Intel® PROSet/Wireless Software", if it is installed. When prompted, choose the option to "Discard settings".
          3. In Control Panel - Device Manager - Network Adapters, right click on the Intel® Centrino® Wireless-N 2230 and Uninstall it. Make sure you mark the option to "Delete the driver software for this device".
          4. Reboot the PC or scan for hardware changes, check device manager again and if an older driver is detected and installed, repeat the actions to uninstall and delete it as well. Repeat this process until the OS does not allow deleting the driver, or until the controller shows as Unknown Device.
          5. Install the Intel® Wireless driver. During the first steps of PROSet/Wireless installation, you can customize the installation and install all driver components.

          • 2. Re: Wifi low speed connection (Intel Centrino Wireless-N 2230)
            hedmah

            Thank you Jonathan for replying my post.

             

            I've already tried to turn off my Bluetooth and change the configuration. Without any different.

             

            For the third method I got stuck at point 4. No mather how many times (I did at least 20 times) I uninstalled it and marked the option "Delete the driver software for this device" I never came to that point that it didn't allowed me deleting it again or showing “Unknown device”. the "Intel Centrino Wireless-N 2230" just came back after scanning for hardware changes  .But I continued to install the Intel® Wireless driver, but it didn't helped out.

             

            One thing that I recognized (after the Wi-Fi turned off and on so many times) was when Wi-Fi turned on and connected to my network it shows a speed of 130mbit/s the first few seconds but after a few seconds it goes back to a slower speed between 6-13 mbit/s. It feels like it adapt itself to a lower pace just after connecting.


            Is there any other way to deal with this?

            • 3. Re: Wifi low speed connection (Intel Centrino Wireless-N 2230)
              jonathan_intel

              It seems you may still have leftovers from previous driver versions. Getting to the Windows® inbox driver before installing the current version may help in this type of cases, as was mentioned in a similar thread: Intel Wireless-N 7260 speed decrease

               

              If the issue persists, try the following actions:

               

              - Look at the Advanced power plan settings and make sure that the Wireless adapter is set to Maximum performance, when plugged in and on battery.

               

              - Go to Device Manager and open the Advanced properties for the Wireless adapter, then set the "802.11n channel width for band 2.4" to 20 MHz only.

               

              - Check with the Access Point manufacturer and obtain the most recent firmware for the device.

               

              - Go the Access Point configuration and try different Wireless channels in order to avoid congestion.