3 Replies Latest reply on Dec 9, 2015 8:31 AM by DiegoV_Intel

    Configuring Edison for a static IP address ...

    DaveFer

      Hi all -

       

      I know this question / topic has been successfully treated in the past. I apologize in advance if this is simply redundent, BUT I wonder if those treatments are still relevant given changes to the Edison image. Every explanation I have found seems obsolete for my image. (I'm using Edison-Image-ww18-15.)

       

      How can I configure my Edison to use a static IP address (and maintain it after reboot)?

       

      I used to do this on a regular basis on BusyBox Linux at work. Apparently, the Yocto Linux image on Edison is sufficiently different that

       

      I have searched for answers to this question here on the Intel forums and abroad on the Internet ... even branching out to search for how to do it on Yocto and double-checking BusyBox isntructions.

       

      Every explanation, tutorial, document, forum post, etc. seems to have instructions that are obsolete for my ww18-15 image. (Either the contents of a file described are COMPLETELY different from the instructions or a command simply doesn't work in any construction similar to the instructions.)

       

      Thanks much for your help.

       

          - Dave F.

        • 1. Re: Configuring Edison for a static IP address ...
          DiegoV_Intel

          Hello DaveFer,

           

          There is a thread with a similar question that has useful comments from other users: Using connman to set up a static IP. Have you checked it?

           

          Regards,

          Diego.

          • 2. Re: Configuring Edison for a static IP address ...
            DaveFer

            Yes, I've read that post and/or posts with nearly identical instructions and the suggested commands do not work for me.

             

            My command:  connmanctl config wlan0 --ipv4 192.168.1.20 255.255.255.0 192.168.1.1

             

            My Result:  "The name net.connman was not provided by any .service files".

             

            (It's hard to interpret since it appears that some value is missing from the error message (in 2 locations).

             

            If course I've tried all sorts of permutations of this command line and also the method described in the device user manual, which is to edit the wpa supplicant config file. But my supplicant config file appears VERY DIFFERENT from the example in that document -- so different that the suggested edits do not apply.


            ALSO, the help from the connmanctl does not cover this level of detail.

             

            As I mentioned in my post, it seems as if all the existing posts on this topic may be stale ... they were created PRIOR to the build I'm using and yet they don't work. I am inclined to believe something has changed since these solutions were posted.

             

                - Dave F.    

            • 3. Re: Configuring Edison for a static IP address ...
              DiegoV_Intel

              Hello DaveFer,

               

              Try with the steps below:

              • Connect to wireless network using connman. Run the following commands in the Edison's console:
              systemctl start connman
              systemctl enable connman
              connmanctl
              enable wifi
              scan wifi
              
              

               

              • Wait for the scan completed message and then run the following command:
              services
              
              

               

              • A list of the available networks will be displayed with the following format:

                        <network name> <service name>

              • Then run the following commands:
              agent on
              connect <service name>
              
              

               

              • At this point you will be asked for the passphrase. Enter the network password and then run the following command:
              exit
              
              

               

              • Now you should be connected to the network. After a successful connection gather the gateway, netmask and broadcast information with the following commands:

                  For gateway information:

              netstat -nr
              
              

               

                  For netmask and broadcast information:

              ifconfig wlan0
              
              

               

              • Now proceed to configure and set the static IP address using the service, gateway and netmask gathered with the following command:
              connmanctl config <service name> --ipv4 manual <ip address> <netmask> <gateway>
              
              

               

              • Edison should have the static IP address set. To maintain it after reboot you have to create and configure the interfaces file. You might need to make the /etc/network/ directory for this. The directory can be created by running the command:
              mkdir /etc/directory
              

               

              • Then create and edit the /etc/network/interfaces file with the following content:
              auto wlan0
              iface wlan0 inet static
              address <ip address>
              netmask <netmask>
              broadcast <bcast>
              gateway <gateway>
              dns-nameservers 192.0.2.2
              wpa-ssid <network name>
              wpa-psk <network password>
              

               

              If the steps are done properly, the Edison should maintain the static IP address set even after reboot.

               

              Regards,

              Diego.