4 Replies Latest reply on Feb 13, 2016 3:43 AM by Srfreson

    NUC NUC5CPYH Does not Boot/Reboot on Ubuntu 15.10 (linux-image-4.2.0-19)

    Hackeron

      I have an Intel NUC NUC5CPYH. This is the unit: http://www.intel.com/content/www/us/en/nuc/nuc-kit-nuc5cpyh.html


      When I try to boot with linux-image-4.2.0 (Ubuntu 15.10) on the latest PY0044 BIOS version, it freezes on boot almost every time. If I downgrade the BIOS to PY0043, it boots most of the time, but when I run "reboot" it freezes almost every single time. This is what I see on the screen when it freezes: Dropbox - IMG_1489.jpg

       

      More details and log files:

       

      1. Reboot issue: Bug #1522201 “NUC NUC5CPYH Does not reboot on Ubuntu 15.10 (linu...” : Bugs : linux package : Ubuntu
      2. Boot issue: Bug #1521749 “NUC NUC5CPYH Does not boot on Ubuntu 15.10 (linux-...” : Bugs : linux package : Ubuntu

       

      I have tried several things:

      • Booting with acpi_osi="Windows 2013" as well as Windows 2015 and Windows 2009, that did not seem to make any difference.
      • I tried adding GRUB_CMDLINE_LINUX="nomodeset" (also: noacpi noapic)
      • I tried disabling devices in the BIOS like audio
      • Tried selecting "Ubuntu, with Linux 4.2.0-19-generic (recovery mode)" from the list, it does not boot into the recovery console either
      • I tried installing a clean 15.10 version on a blank hard drive to rule out any configuration issues
      • I tried cold booting/rebooting and warm booting/rebooting (+5V standby), it does not seem to make any difference


      Any ideas?


        • 1. Re: NUC NUC5CPYH Does not Boot/Reboot on Ubuntu 15.10 (linux-image-4.2.0-19)
          ekaftan

          Hi,

           

          I have two DN2820FYK units.

           

          One is running BIOS version 30 and reboots fine. It does have a problem where a poweroff also reboots the machine but I can live with that.

           

          The second unit had some problems with SUSE Linux Enterprise 11SP3 so I updated the BIOS to version 50. That fixed the problem I had with SUSE but now that I need that unit running Ubuntu, neither reboot nor shutdown works.

           

          I upgraded the BIOS today to version 52 and that made reboot work until I removed power. After powering the unit back up, reboot no longer works.

           

          I know I am not running a 'tested' version, but I think this is a BIOS bug.

          • 2. Re: NUC NUC5CPYH Does not Boot/Reboot on Ubuntu 15.10 (linux-image-4.2.0-19)
            ekaftan

            Replying to myself to get this registered.

             

            I downgraded the newer-bios NUC to kernel 3.13.0-24 and it now reboots just fine.

             

            Maybe an incompatibility between newer BIOSes and newer ubuntu kernels?

            • 3. Re: NUC NUC5CPYH Does not Boot/Reboot on Ubuntu 15.10 (linux-image-4.2.0-19)
              allan_intel

              Thank you for the information, this is good help for others with same problem.


              Allan.

              • 4. Re: NUC NUC5CPYH Does not Boot/Reboot on Ubuntu 15.10 (linux-image-4.2.0-19)
                Srfreson

                Hi,

                 

                We have a similar problem.

                 

                We're using Intel NUC NUC5CPYH for a project, with lubuntu 14.04.03.

                 

                Sometimes (it's something random) when the pc is going to shut down (or rebooted) it gets stuck at the lubuntu dots animation. If we disable the animation, we can see that it remains at the message :
                * WILL NOW HALT

                [numbers] reboot : Power down

                 

                The only way of making them to work again, is to press the power button manually or to unplug and plug them again to the power supply.

                 

                There's nothing wrong at the lubuntu logs.

                 

                We have tried different kernels, different values for Intel Idle Max State, and we're running out of ideas.

                 

                With the same iso, but using previous NUC DN2820FYKH, we didn't have this problem (and we have around 200 nucs of that model working).

                 

                This is something too important for us, because our customers are dissapointed as they don't know what to expect each day.

                 

                As you talk about BIOS update, we'll have to try it. Now we send the NUCs with the Bios 44.

                 

                Best regards