5 Replies Latest reply on Dec 19, 2009 2:39 PM by phil_l

    DP55WG- cant flash BIOS

    painter

      Brand new DP55WG. Has initial BIOS ver 3206 8/5/2009. 4 DDR3-1600 x 2 MB ram (8gb total), 1TB Hitachi in sata 0. sony optiarc dvd/cd in sata 3. BIOS shows the hitachi and sony. Boot from USB is enabled.

       

      I created from the latest BIOS update 3878 10/28/2009 iso on a cd-rw media and the same for the iflash on a 4gb usb memory stick.

       

      Problem 1. The BIOS will not even boot while the USB memory stick is inserted in any of the USB ports (front or back).

       

      Problem 2. If I insert the iso-created cd/rw (and remove the usb memory stick) I can get it to boot to the linux loader boot prompt. When I hit enter it loads linux but very soon reports it cannot find the cdrom drive.

       

      Both of these seem to be very fundamental yet serious problems with this MB.

      Help!

        • 1. Re: DP55WG- cant flash BIOS
          phil_l

          Hi

           

          I have this board and used the ISO method without any problems.  The USB method doesn't create a bootable USB stick so not booting sounds right.  What you will get on the newest BIOS upgrade for next time is the option to flash from USB during boot where it will look for the file on the stick and flash from that.

           

          I would try if you haven't already setting the SATA controller to IDE mode then booting from the CDROM, does this help?

           

          If not...

           

          Unplug the hard-drive and put the CDROM in SATA port 0, then try again.

           

          If you have installed an OS already and that is working you can update from Windows.

           

          Best Regards

           

          Phil

          • 2. Re: DP55WG- cant flash BIOS
            painter

            Thanks for the suggestion. Unfortunately, it did not change anything when I removed the sata disc drive in sata0 and moved the sata dvd/cd to sata0. I still get the BIOS ISO-created boot loader prompt and then "can't open cd driver".

             

            Do I have to do anything with the BIOS Jumper? It is set to Normal according to the user manual page 57.

             

            Please note that using the Ubuntu 9.10 ISO-created cd-r in the original sata3 I was able to install ubuntu.

             

            The cd I'm using for the BIOS update is a cd-rw. Could this be a problem?

             

            >> I repeated the attempt using just a cd-r and got the same failing results.

             

            Any other ideas?

             

            Message was edited by: painter

            • 3. Re: DP55WG- cant flash BIOS
              phil_l

              Hi

               

              I have no other suggestions, it is very strange it isn't working.  How did you create the disc from the ISO, perhaps it isn't quite right.  I created the ISO using Windows 7 ISO burner on CD-RW and it boots to some form of Linux, then quickly reboots and flashes the BIOS.

               

              What about using this method:

               

              http://www.intel.com/support/motherboards/desktop/sb/CS-030144.htm

               

              Regards

               

              Phil

              • 4. Re: DP55WG- cant flash BIOS
                painter

                I had long ago tried that but maybe I didn't do something required. This is a catch 22. The F7 flash does not work correctly in the original BIOS as far as I can tell. A hint is in the BIOS update 1 (ver 3456 8/21/2009) release notes that there were changes for USB booting, etc.

                 

                If I insert any USB flash drive it will simply hang the BIOS startup. If I don't insert the USB drive but leave in the CD BIOS updater when I use F7 it throws up a BIOS utility that shows my Sony Optiarc dvd/cd and a rescan menu item BUT no keyboard keys work at that point so I can't do anything. Note that the screens that are indicated in the F7 flash documentation do not look or work as advertised from the original BIOS version which this MB is at. It seems I can't get there at all.

                 

                I am new to this platform. I have used AMD for 16 years and this is my first Intel. I'm not impressed because these are fundamental MB features that absolutely must work

                 

                I hope some Intel tech person reads this and offers a true solution because I have run out of options.

                 

                thanks for trying.

                 

                >> UPDATE- some success!

                 

                First of all there is only one BIOS splash screen menu item in the initial release (ver 3206 8/5/2009) and that is the F2. No others, including no F7.

                 

                Second, when I tried the F7 when I saw the BIOS splash I got the BIOS update menu as I had reported BUT it never responded to keyboard input.

                 

                Third, I went back to this and tried it again yet nothing happened... However, I left this for a few minutes to do some googling on this matter and when I looked back I saw some screen changes that seemed to indicate that it might be working!

                 

                Fourth, I started over. Hit the F7 when I saw the F2 splash. Got the BIOS update screen. My sony Optiarc was displayed as usual (on sata3 where I put it back to). I hit the ENTER key and waited. After about 3 minutes of no apparent system activity (yes an eternity but why?) it listed a new screen with some isolinux entry and a kg3878c.bio entry. I selected the kg3878c.bio entry. The system powered down (which surprised me), powered back up and the screen text indicated it was doing a series of BIOS updating.

                 

                So, it worked. However, Intel should document this in the BIOS updating instructions because it is not at all like what they said.

                 

                Also, I want to know why there is a file name difference between those listed and downloadable from the update page http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18303&ProdId=3066&lang=eng

                and what gets constructed on the cd by using the ISO image. Specifically, the file on the update page is KG3878P.BIO yet when you use the ISO file there KG3878P.ISO that creates a file on the cd named kg3878c.bio. Why the difference? Is it just a different file name but the same contents? Or is there something different as implied by the name difference? This only leads to confusion.

                 

                I hope this helps others but I have to say that Intel needs to make a lot of documentation improvements.

                 

                I'm leaving the status as NOT ANSWERED in the hopes that Intel will still read this and fix the docs...

                 

                Message was edited by: painter

                • 5. Re: DP55WG- cant flash BIOS
                  phil_l

                  Hi

                   

                  Good news you finally managed to get the BIOS updated, I agree it is pretty poor that you should have these problems.  I too had problems with this board and that until I deleted partitions and reformatted the hard-drive it hung when AHCI was enabled, yet the drive worked perfectly on a previous system.  Never had a problem like that before with a motherboard.

                   

                  Hopefully with the latest BIOS you had now updating to any newer version will be easier.

                   

                  Regards

                   

                  Phil