9 Replies Latest reply on Dec 9, 2015 2:41 PM by poseid

    No Wifi at startup

    poseid

      Hi,

       

      I played with the Wifi setup to make the Intel Edison a Wifi Access Point.

       

      Now, I want to undo my configuration, but I can't make it work anymore. I can login via USB and serial communication.

       

      First, I tried to run ifdown and ifup, but this gives:

       

          root@eddie:~# ifdown wlan0

          ifdown: can't open '/etc/network/interfaces': No such file or directory

       

      (why would this not work on the Edison?)

       

      Then, I saw during boot, that I should run:

       

          root@eddie:~# systemctl status -l wpa_supplicant.service

       

      This gave me:

       

      Oct 18 14:30:35 eddie wpa_supplicant[184]: Successfully initialized wpa_supplicant

      Oct 18 14:30:35 eddie wpa_supplicant[184]: nl80211: Driver does not support authentication/association or connect commands

      Oct 18 14:30:35 eddie wpa_supplicant[184]: Could not read interface wlan0 flags: No such device

      Oct 18 14:30:35 eddie wpa_supplicant[184]: wlan0: Failed to initialize driver interface

      Oct 18 14:30:36 eddie systemd[1]: wpa_supplicant.service: main process exited, code=exited, status=255/n/a

      Oct 18 14:30:39 eddie systemd[1]: Failed to start WPA supplicant service.

      Oct 18 14:30:39 eddie systemd[1]: Unit wpa_supplicant.service entered failed state.

       

      Now, I can configure wpa_supplicant (btw, what is that), with configure_edison --wifi

       

      Wifi will work, but a bit more background how to make this automatically during boot would be nice.

       

      Thanks!

        • 1. Re: No Wifi at startup
          Intel_Alvarado

          Hi,

           

          The ifup and ifdown will not work on the Edison. The Edison’s image is based on Yocto and has other features to allow you to change the interfaces configuration. There isn’t a /etc/network/interfaces file in the Edison’s image. You can see more information on the interfaces if you look at /etc/wpa_supplicant/wpa_supplicant.conf.

           

          I’m not following that last part; the error you posted is the output of running systemctl status -l wpa_supplicant.service? And what is your goal, to have Wi-Fi enabled automatically after boot? To have Wi-Fi enabled after boot you need to go through the steps in configure_edison –setup and have the latest image, what image are you using, what version?

           

          Sergio

          • 2. Re: No Wifi at startup
            poseid

            Thanks.

             

            I had the Edison acting as Access Point (Wifi "provider") where I could connect e.g. with my phone.

            Now, I want to have the Edison working again as consumer of Wifi, so, removing the Access Point settings. Indeed, when the device boots it should connect to the latest wpa_supplicant network.

             

            Indeed, I tried to flash to the latest image (intel-iot), this results in:

             

            uname -a

            Linux edison 3.10.17-poky-edison+ #1 SMP PREEMPT Wed Aug 20 16:09:18 CEST 2014 i686 GNU/Linux

             

            Is there another option to see what image is installed?

            • 3. Re: No Wifi at startup
              Intel_Alvarado

              Use the command configure_edison –version. The latest version should output 159.devkit.

               

              Sergio

              • 4. Re: No Wifi at startup
                poseid

                Thanks, actually I get no version:

                 

                root@edison:~# configure_edison --version

                Incorrect input. Redirecting to --help

                 

                 

                  Interactive configuration options:

                    (none)                  Goes through changing the device name, password, and wifi options.

                    --name or -n            Changes the device name

                    --password or -p        Changes the device password

                    --wifi or -w            Changes the wifi options

                 

                 

                  Non-interactive configuration options

                    --changePassword        Changes the device password to the following argument

                    --changeName            Changes the device name to the following argument

                 

                 

                  Other options

                    --help or -h        Displays these help options

                    --server            Starts the server (testing only)

                 

                On an older Edison Image, I remember to had 124 iirc.

                • 5. Re: No Wifi at startup
                  poseid

                  With this same image, I currently get also errors on configure_edison --wifi

                   

                  Configure Edison: WiFi Connection

                   

                   

                  Failed to connect to non-global ctrl_ifname: (null)  error: No such file or directory

                  Failed to connect to non-global ctrl_ifname: (null)  error: No such file or directory

                   

                   

                   

                   

                  0 :     Rescan for networks

                  1 :     Manually input a hidden SSID

                   

                   

                   

                   

                  Enter 0 to rescan for networks.

                  Enter 1 to input a hidden network SSID:

                  • 6. Re: No Wifi at startup
                    Intel_Alvarado

                    If the output of configure_edison –version is not 159 then you are not using the latest version. I’d suggest you to re flash your Edison with the latest image using the Flash Tool Lite. IoT - Flash Tool Lite User Manual | Intel® Developer Zone 

                    The latest image can be downloaded here http://downloadmirror.intel.com/25028/eng/edison-image-ww25.5-15.zip

                     

                    Let me know your results.

                     

                    Sergio

                    • 7. Re: No Wifi at startup
                      poseid

                      Thanks, Sergio.

                       

                      I am trying, but as I am on MacOS it is a bit hard.

                      I tried on the Edison: "reboot ota", and at least the image was restored, I get now

                       

                         root@edison:~# configure_edison --version

                         120

                       

                      But unfortunately, the Edison does not show up as USB device, i.e. with ./flashall.sh the USB ID is not seen:

                       

                      USB_VID=8087

                      USB_PID=0a99

                      TIMEOUT_SEC=60

                       

                      hmm... I am thinking how to copy the files to the board with another approach, but not sure.

                      • 8. Re: No Wifi at startup
                        poseid

                        * new learnings: I need to make sure that both USB cables are connected

                        * flash lite tool shows edison then, but dfu-util -l not yet

                        * now trying to copy files via mounted drive

                        • 9. Re: No Wifi at startup
                          poseid

                          Yes, it worked now!

                           

                          With 2 USB cables, copying files to a drive EDISON_F32 was possible as discussed in http://www.helios.de/heliosapp/edison/index.html#Flashing_latest_Intel_Edison_fir

                           

                          Then /sbin/reboot ota did work fine:

                           

                           

                          Poky (Yocto Project Reference Distro) 1.7.2 edison ttyMFD2

                           

                           

                          edison login: root

                          root@edison:~# configure_edison --version

                          159