0 Replies Latest reply on Nov 27, 2015 4:07 PM by dancarr0743

    WIDI not compatible with I7 2670QM processor.

    dancarr0743

      I bought an I7 2670QM WIDI and cannot upgrade it to W10. Worked fine with  W7 but not compatible with W10. I bought this specifically for WIDI. I am not happy.