1 2 Previous Next 25 Replies Latest reply on Jan 16, 2016 4:31 AM by Dalinian

    Intel NUC i7 is a brick, HELP!!

    snowpine

      Greetings, I am running (or rather WAS running) Fedora 23 on my Intel Nuc i7 kit with latest BIOS updates.

       

      Following a failure to wake from suspend, my Intel is now a brick... the system will not boot and is completely unresponsive. No LEDs. No beeps. No fans. No video output. No sign of life whatsoever. HELP!!!

       

      ps I was disappointed to notice NUC i7 uses the Sunon MagLev GB0555PDV1-A fan. This is the same cooling solution Intel uses in the Celeron NUCs that generate 1/8th the heat! My i7 NUC (before it died) was running 90+ degrees C under heavy processor load with the noisy fan on full blast. Is it possible to install an upgraded or aftermarket fan that will keep my NUC at a reasonable temperature? I am concerned that the high internal temperatures will damage my hard drive leading to possible data loss.

        • 1. Re: Intel NUC i7 is a brick, HELP!!
          ozzy@intel.com

          Try disconnecting the CMOS chip from its battery for a minute - that will most probably bring it back to life.

          • 2. Re: Intel NUC i7 is a brick, HELP!!
            Apachez

            For more info NUC failure after Linux sleep / hibernate / suspend: SOLUTION(?)

             

            Dont forget to file this as a bug report to intel so they will fix it for other NUC models aswell (dunno why they havent - its not like its an unknown bug when it comes to various NUC models).

            • 3. Re: Intel NUC i7 is a brick, HELP!!
              mikec_intel

              Hi snowpine,

               

              I apologize for the inconvenience. Our Intel® NUC Kit 5i7RYH has 3 years of warranty, please request a replacement through our Contact Support team.

               

              Regards,
              Mike C

              • 4. Re: Intel NUC i7 is a brick, HELP!!
                snowpine

                Hi Ozzy, thanks for your help! Resetting the CMOS battery allowed me to power on the computer as you suggested. Do you have a link to where I should file a bug report? The steps are highly reproducable:

                 

                1. Attach USB keyboard (tested: Happy Hacking 2.0)
                2. Install Linux (tested: Fedora 22, Fedora 23, Mint 17.2)
                3. Suspend computer
                4. Detach USB keyboard
                5. Reattach USB keyboard
                6. NUC does not wake on key press
                7. Disconnect power
                8. NUC is bricked

                 

                Mike C, thank you for your offer. Are you telling me that Intel has solved the NUC power management and overheating, and you can send me a NUC that does not have these same issues? Or are you offering to send me an identical NUC that will have the exact same problems?

                • 5. Re: Intel NUC i7 is a brick, HELP!!
                  snowpine

                  In layman's terms I can summarize the problem:

                   

                  1. I have a favorite keyboard.
                  2. I unplug my keyboard from NUC to use with a different computer.
                  3. When I plug the keyboard back into NUC, pressing a key does not wake it from suspend.
                  • 6. Re: Intel NUC i7 is a brick, HELP!!
                    MrMitch

                    I tried the same steps you mentioned using Windows 10 and when I remove and replace the USB keyboard, the keyboard does not wake the system. I have to press the Power Button.  This is normal because you are confusing the USB subsystem when the system is in S3 sleep.  Pressing the Power Button does wake the system and Windows re-enumerates USB and everything is fine then.

                     

                    I don't know how Fedora handles S3 and USB but this should work as well.  Try plugging in your USB keyboard first, then waking the system using the Power Button.

                    • 7. Re: Intel NUC i7 is a brick, HELP!!
                      snowpine

                      Thanks Mr Mitch. I will concede the point that the NUC's inability to resume from USB keyboard is a "feature not a bug." (I will point out, though, that pressing the power button may not always be a convenient option for users who have purchased the NUC for VESA mount, kiosks, digital signage, etc.)

                       

                      The larger and more troubling issue is the NUC's failure to recovery gracefully following a suspend failure. My consumer expectation is that, if I unplug my computer, plug it back in again, and press the power button... it should turn on. I have never (before now) owned a computer that it was necessary to remove the motherboard and CMOS battery to wake from suspend.

                      • 8. Re: Intel NUC i7 is a brick, HELP!!
                        snowpine

                        Upon further research I see that my NUC suspend problems are not unique to me. Intel has known of this problem for a year, and has offered no fix beyond "use Windows, or send it back for warranty and we'll send you a new one with the exact same problem." Therefore I have returned my unsatisfactory purchase and will be sure to let my pals in the Linux community know the truth about the Intel NUC.

                         

                        --Snowpine

                        • 9. Re: Intel NUC i7 is a brick, HELP!!
                          mikec_intel

                          Hi snowpine,

                           

                          I believe you are experiencing a compatibility issue. Intel’s has a department specialized on Open source operating systems. I suggest you to contact them, maybe they can explain you what kernel changes are needed.

                          Contact Us | 01.org

                           

                          Regards,
                          Mike C

                          • 10. Re: Intel NUC i7 is a brick, HELP!!
                            snowpine

                            Hi Mike C, glad to see a decision maker at Intel is taking an interest in the well-known "Linux-NUC Suspend-Brick" problem. What an odd suggestion that *I* should contact 01.org to educate myself about the inner workings of the Intel NUC; isn't that kind of like *your* job? If you can fix this bug and make the NUC Linux-compatible, then you will become a hero to the Linux community, and I see a raise and promotion in your future. Good luck!

                            • 11. Re: Intel NUC i7 is a brick, HELP!!
                              mikec_intel

                              Hi snowpine,

                               

                              Let me know the version of Fedora that you are using if it is possible send me the BIOS settings that you have now. If you are not using the stock kernel, send me an image of the OS.

                               

                              Regards,
                              Mike C

                              • 12. Re: Intel NUC i7 is a brick, HELP!!
                                snowpine

                                Hi Mike, thanks for your speedy reply. My NUC has been returned, so you are welcome to run whatever tests you like on it.

                                 

                                The Linux distributions I tested include: Fedora 22, Fedora 23, Linux Mint 17.2, Linux Mint 17.3.

                                • 13. Re: Intel NUC i7 is a brick, HELP!!
                                  mikec_intel

                                  Hi snowpine,

                                   

                                  I tested with Linux Mint 17.3 -Cinnamon-64bit, using dual Boot with Windows® 10 64bit and BIOS version 0350 and NUC wakes up after suspend mode pressing the power button. I tested after 2, 5 and 15 minutes.

                                   

                                  I repeated the test using the model 5i5RYK, both work properly.

                                   

                                  Regards,
                                  Mike C

                                  • 14. Re: Intel NUC i7 is a brick, HELP!!
                                    snowpine

                                    Hi Mike C, sorry to hear you are having trouble reproducing the bug. I've worked in tech support before, and understand how frustrating that can be. Unfortunately, I have already returned my NUC, so the amount of information/assistance I can provide is limited. I suggest you check in with user Tim (Dalinian) who has taken great pains to document the bug in detail, and still has a NUC in his possession.

                                     

                                    NUC5i5RYH Bricked by Ubuntu Suspend for Fifth Time

                                     

                                    User 'bjthinks' said it best in his reply to you, Mike C, on Nov. 27, 2015 (did you read it?): "I have no idea what you want me to 'test'. The NUC works flawlessly with pm_async set to 0, and bricks itself when going to sleep with pm_async set to the default. I'm providing this information to other NUC owners and Intel engineers who can make use of it. It does not appear that you can."

                                     

                                    NUC failure after Linux sleep / hibernate / suspend: SOLUTION(?)

                                     

                                    Last but not least, a gentle reminder that this issue has been known to Intel since at least 2014, Snowpine is not bringing a new problem to your attention, but simply adding his voice to the chorus!

                                     

                                    Re: NUC dead after suspend mode in Ubuntu 14.10

                                    1 2 Previous Next