13 Replies Latest reply on May 31, 2016 7:27 AM by orange109

    NUC5CPYH HEADLESS

    JHaro

      Few montth ago I bought a NUC2820FYKH to test the NUC platform as an embedded headless server, It worked perfect during a couple of months.

       

      Now we have buy 5 NUC5CPYH and they work perfect if we have an vga display connected. If we remove the display and reboot the system the NUC doesn't boot !!! .

       

      We have to connect again the display and switch on again the NUC and start to work perfectly.

       

      But this only happens with NUC5CPYH not with NUC2820, I have updated the bios to PY0044 but we still have the same problem.

       

      The only solution at the moment is to install an VGA Dummy plug, but this is no professional at all.

       

      Is there any software solution to this problem?

       

      Regards

       

           Jesus Haro

        • 1. Re: NUC5CPYH HEADLESS
          mikec_intel

          Hi JHaro,

           

          I suggest you to try with the following workaround.

           

          Remote Access to Intel® NUCs

          Intel® NUC Boards and Kits — Remote Access to Intel® NUCs

           

          Regards,
          Mike C

          • 2. Re: NUC5CPYH HEADLESS
            KDD

            Same old useless answer I've been getting about this same problem on other NUC models. How is software going to help him when the NUC won't even complete POST? It doesn't even try to boot the OS!

            • 3. Re: NUC5CPYH HEADLESS
              Apachez

              To mikec_intel's defence there are some good links over at that page:

               

              fit-Headless:

              http://www.fit-pc.com/web/products/fit-headless/

               

              VGA Dummy

              The Personal Computer - VGA Dummy

               

              Dr HDMI

              Welcome to Doctor HDMI

               

              File this as a bugreport, unless there are hardware limitations the bios should be able to overrule the output chip and continue to output signal (as if you got lets say the displayport plugged in during boot and then removed it). That is Intel should be able to fix this through a BIOS update. However its not uncommon that if you didnt have any monitor plugged in during boot the full output is being disabled by the bios (or if its the output chip itself).

              • 4. Re: NUC5CPYH HEADLESS
                afremont

                I'm running a NUC5PPYH headless and it seems to be doing okay.  I'm running Mythbuntu with kernel 4.2.1.  I'm also running hostapd to make the wifi into an access point.  I can reboot it and list off the BIOS settings if you like.  I think it's only in UEFI mode, but I'm not sure on that. 

                 

                According to xdpyinfo (run in a ssh session with an environment variable setting DISPLAY=:0.0), it would appear that the display has defaulted to 1024x768 with nothing connected.  If I plug a monitor into the HDMI jack, nothing appears until I press the power button to initiate a shutdown, then an image appears.  I don't know what resolution it is in at that point.  Unfortunately I don't have any experience with other NUC models.

                • 5. Re: NUC5CPYH HEADLESS
                  JHaro

                  It's not a OS problem, the OS doesn´t start, as I said, we have checked the same hard disk in NUC2820FYKH and in NUC5CPYH.

                   

                   

                  It's a BIOS problem, the NUC5CPYH comes with 043 and we have updated it to 044 version but we still have the same problem.

                   

                   

                  If you look for the NUC5CPYH in the network, you can't find it, there are no logs ...

                   

                   

                  If I install a Dummy VGA (3 resistors) everything works perfect but why I have to put 3 resistors ...

                   

                   

                  If you look at Intel NUC board NUC5CPYB Technical Product Specifications:

                   

                   

                  Chapter 3.7.2 Booting Without Attached Devices

                   

                   

                  For use in embedded applications, the BIOS has been designed so that after passing the POST,

                   

                  the operating system loader is invoked even if the following devices are not present:

                   

                  Video adapter

                   

                  Keyboard

                   

                  Mouse

                  • 6. Re: NUC5CPYH HEADLESS
                    JHaro

                    Hi afremont, which BIOS version are you using??

                    • 7. Re: NUC5CPYH HEADLESS
                      afremont

                      PYBSWCEL.86A.0043.2015.0904.1904  I'm guessing that isn't the latest BIOS.  I didn't see any way to download that version from their site either.

                       

                      (RANT) I've always liked Intel chipsets and CPUs, but I've never much liked their boards.  I like the NUC okay, but I'm disappointed in it not having an M2 connector for an SSD and it only having one SODIMM socket.  I don't understand intentionally leaving out things that would improve performance.  From what I understand, dual memory sockets would help it with some multimedia video things.

                       

                      I won't be updating my BIOS since I absolutely need it to work in headless mode for a while.  I agree that sticking something on the VGA connector to make it boot is lame.  One weird thing is that it always tells me that the network is disconnected and if I click on UPDATE, it gives me an error about failing to load the product catalog. 

                      (/RANT)

                       

                      Is there anything in the "event log"?

                      • 8. Re: NUC5CPYH HEADLESS
                        MobiusNZ

                        I've discovered this too and its already wasted a fair amount of my time - I use basic Celeron NUC's as Spam gateways in front of Clients Exchange servers and they have always served very well - Got one of this model the other day - Configured it all and got my staff to run out and install it onsite (with just power and Network cable) and I couldn't remote access it. Drove down there again and plugged in a screen and keyboard and it wouldn't wake - Put it down to keyboard detection so forced a reboot (Power off and on) and got into it all ok - Checked and found one network issue (DNS) and fixed it scratching my head and went back to the office. Logged in and did some configuration remotely and rebooted it and again - Couldn't access it as it didn't post.

                         

                        As of this minute my client has a stunning tiny, discreet NUC in their server cabinet with a big ugly 17" LCD screen plugged into it so it will POST!!!! I can only find VGA dummy plugs overseas which will take forever to get here and will end up costing around $50 (Which is 25% of the cost of the bare nuc without Ram or disk) - I can try and source a plug set and soldier one up myself which will be cheaper but time consuming and Ugly (as cheap grey plastic with a hole for the cable at the end).

                         

                        I could source another NUC of a different model but thats more wasted time preparing it and it's already cost me over $150 of otherwise billable time driving there and back twice.

                         

                        A) Intel need to admin they have stuffed up on this model as trying to insinuate its a "feature" not a fault is rubbish, prior models have worked and I'm willing to put money on the fact that future versions will no longer have this "feature".

                         

                        B) If it is hardware related and can't be fixed with a bios update (I've installed the latest bios as at yesterday) then at least get some nicely made discreet and professional looking dummy VGA connectors out to your distributors either free or at least at a reasonable cost (I wouldn't expect to pay more than $5 wholesale - I'm an Intel VAR in New Zealand)

                         

                        I look forward to an official response from Intel?

                        • 9. Re: NUC5CPYH HEADLESS
                          mikec_intel

                          Hi MobiusNZ,

                           

                          I regret for the inconvenience. I suggest you to get in contact with your channel representative.

                           

                          From communities we provide technical support on Intel products in this case it is a product limitation. It requires an external device.

                           

                          I am going to pass your concerns with my upper level.

                          Regards,
                          Mike C

                          • 10. Re: NUC5CPYH HEADLESS
                            Intel Corporation
                            This message was posted by Intel Corporation on behalf of

                            Hi MobiusNZ,
                             
                            I regret for the inconvenience. I suggest you to get in contact with your channel representative.
                             
                            From communities we provide technical support on Intel products in this case it is a product limitation. It requires an external device.
                             
                            I am going to pass your concerns with my upper level from my side.
                             
                            Regards,
                            Mike C

                            • 11. Re: NUC5CPYH HEADLESS
                              KDD

                              Hogwash, the ability to boot headless could easily be corrected in a BIOS revision. The level of support from Intel on this forum continues to disappoint. The couple of guys who frequent this forum that are former Intel employees(and US based) are more informative/helpful than the current employees(which seem to be not US based).

                              • 12. Re: NUC5CPYH HEADLESS
                                rguevara

                                Hi Jesus Haro,

                                 

                                The situation that you are reporting is a known issue on the NUC5CPYH, this condition has been reported to engineering and there could be a fix for it eventually but it is not confirmed and I cannot promise you that.

                                The workaround for that is to plug a "dummy VGA adapter" which you already did and I agree it is not the best solution, I apologize for that.


                                Regards,

                                Ronny G

                                • 13. Re: NUC5CPYH HEADLESS
                                  orange109

                                  I've complained about this myself on another post I started:

                                  Booting headless with the new NUC5CPYH (Celeron based)

                                   

                                  This is really pathetic to be honest, with all respect.

                                   

                                  You guys (Intel NUC crew/s) should have a 'to do list'! In which you would have issues you need to solve first before releasing new models.

                                   

                                  It's pretty f***** up that you release a new model with a problem that was complained about over and over again in previous models and that you've solved in previous version but do not provide a fix for the newer models.

                                   

                                  Please FIX it already.

                                   

                                  Regards,