6 Replies Latest reply on Nov 28, 2015 5:07 PM by JoshuaPK

    Latest firmware is bigger than MMC

    beckmx

      Hello guys, I had several issues, first I wanted to updated my edison but it bricked, then I restored it but I noticed the edison didnt want to do any wifi scans, then I wanted to erase the MMC info and noticed the max available space is 803MB but the latest image is now 1GB.

       

      Any ideas on how to return to previous relases?

        • 1. Re: Latest firmware is bigger than MMC
          EnVy_28

          You have to use the "Intel Phone Flash Tool" to update the edison's firmware to the latest yocto release...

          • 2. Re: Latest firmware is bigger than MMC
            beckmx

            I did use the flash tool but after doing that I cannot run arduino sketches nor WIFI connections, I just would like to reflash the previouse firmware release

            • 3. Re: Latest firmware is bigger than MMC
              EnVy_28

              Go to this link:

              IoT - Intel® Edison Board Download | Intel® Developer Zone

               

              Then check the "Previous versions" Section

              • 4. Re: Latest firmware is bigger than MMC
                DiegoV_Intel

                Hello beckmx,

                 

                The latest Yocto image has to be flashed using the Flash Tool Lite. The other method of copying and pasting the image files in the Edison's drive is no longer used. Please check the following document for additional details about the old and the new flashing methods: Flashing the Edison Module

                 

                Regarding the issue with the Arduino sketches, the latest image has a known issue with the sketches. That might be the same issue that you described. If you want to flash an older version, I recommend you to flash the 146 version which doesn't have issues with the Arduino sketches. The 146 version can be downloaded from the following site: Intel Edison Software Release 2.1

                 

                If you want to keep using the latest image (the 159 version), then I suggest you to check the following thread where a user shared a workaround for the issue of the Arduino sketches: Run Arduino sketch on boot Workaround. However, notice that you would have to re-flash the Edison with the 146 version to perform the workaround, so you might prefer to stay in that version -146- since you would have to flash it anyway.

                 

                Regards,

                Diego.

                • 5. Re: Latest firmware is bigger than MMC
                  JoshuaPK

                  Hello DiegoV_Intel!

                   

                  There HAS to be some way to flash this latest firmware without using Flash Tool Lite.  The Flash Tool does something to exclude some of the bits of the firmware image so that it all fits on MMC.  Why not publish information on exactly what bits it excludes, so that alternate flashing methods can be developed?  Forcing users to use the Flash Tool presents a problem to those of us who simply can't use it.

                   

                  I have three Edisons: two of them came with the Intel mini-breakout board, and one of them came with a SparkFun kit that includes the SparkFun base board.  One Edison is defective and I'm going to return it to the store to get another.  Two of the Edisons work fine in the SparkFun base board- that is, I can connect the CONSOLE connector to my USB port and connect via screen to see the boot messages and get a login prompt.  NONE of the Edisons do anything whatsoever when plugged into any of the Intel mini-breakout boards.  Those breakout boards do something weird: no matter what OS, they will connect, wait a minute, then disconnect, over and over again.  You can see it doing this in the kernel messages on the host.  I've tried connecting to a USB3 port, USB2 port, and via a USB2 hub.  The SparkFun board works in any of those configurations but the Intel board doesn't work in any of those configurations.

                   

                  Unfortunately, the Flash Tool Lite (and the IOT XDK) does NOT see any of the Edisons when they're on the SparkFun base board, even when I can see those Edisons via the console.  So I can have the Edison join my wireless network and I can probably write C++ apps for it, but I can't do anything with any of the other supported languages (i.e. NodeJS) since none of the Intel software will see any of the Edisons on the SparkFun board.  Apparently I also can't use the latest version of the firmware, since it requires the use of Flash Tool.

                   

                  Oh, and a word on OS's- I've tried this on Ubuntu 14.04.3 LTS; Windows 7 Professional; Windows 8.1 Professional; CentOS.  I normally only use CentOS, but I installed the other three OS's today in order to try to get these Edisons working properly.  Connecting to the console works under any OS, but the Flash Tool Lite does not work in any of the Windows versions or Ubuntu.

                   

                  So what bits can we remove from the firmware image download so that it fits on MMC?

                   

                  Thanks!

                  -JK

                  • 6. Re: Latest firmware is bigger than MMC
                    JoshuaPK

                    I was finally able to get the two working Edisons flashed with the latest firmware.  For some reason the mini-breakout board started working, kinda.  The Flash Tool was able to see the Edisons on the breakout board and flash them.  However, the IOT Toolkit still does not see any of the Edisons on the breakout board, at least under Ubuntu it doesn't.  But that's a topic for another thread.