3 Replies Latest reply on Nov 30, 2015 4:48 PM by CMata_Intel

    Changing the default $TERM to xterm-256color

    Alva

      I am running into a really weird problem with Edison/Yocto.

       

      If I SSH into Edison through wifi, the terminal is set to xterm-256color (checked using 'echo $TERM'). This is the expected behavior.

      However, if I try to use screen to access Edison, the $TERM is set to 'xterm' by default, and not xterm-256color. I tried changing $TERM in bash on Edison as well as passing in TERM variable while inputting the screen command, but to no avail.

       

      I need to use Edison over my School's network, therefore I cannot ssh over wifi. Not having 'xterm-256color' as my terminal emulator is making using programs such as vim on Edison really difficult.

       

      Any help would be appreciated!

       

      Thank you.

        • 1. Re: Changing the default $TERM to xterm-256color
          CMata_Intel

          Hi Alva

           

          Which image are you using? I ran echo $TERM through SSH and Cable with 159 and 159.devkit versions and I always got xterm as result (by default).

          What have you tried to change the TERM variable?

          You can set this variable using the Serial Terminal with export TERM=xterm-256color

          If you are using PUTTY to ssh you can also set the use of colours in the settings of the software.

           

          Regards,

          Charlie

          • 2. Re: Changing the default $TERM to xterm-256color
            Alva

            CMata_Intel

             

            I am using OSX to access Edison using 'screen'. Changing the TERM variable is effective i.e. echo $TERM outputs xterm-256color now. But the terminal behaves very weirdly.

            This is how my terminal looks like. Notice how the background is only black behind the text, and the number of rows is only half the screen. This does not happen when I ssh into the system, but for reasons beyond my control, I'm not able to while working on it.

            Screenshot 2015-11-26 15.20.10.png

            • 3. Re: Changing the default $TERM to xterm-256color
              CMata_Intel

              Hi Alva

               

              Have you tried by changing the preferences of the Terminal Window?

              About the number of lines while using vi, if you are using a Terminal Emulator through the USB port, you will see fewer rows than using a Terminal Emulator through SSH. You can scroll up and down by pressing ESC and then CTRL+U or CTRL+D respectively.

               

              Regards,

              Charlie