4 Replies Latest reply on Nov 25, 2015 4:31 AM by NonameUser

    How to restore factory settings on Intel Edison hardware

    NonameUser

      Hi,

      I have tried to detach console from UART 2 using SSH with commands:

      - fw_setenv bootargs_console

      - shutdown -r now

      After reboot my wi-fi connection disapeared, so right now I can not log in edison using serial and ssh.

      I think that I need to reset edison to factory settings hardware style (I am using mini breakout board)

      Can anyone help me?)

        • 1. Re: How to restore factory settings on Intel Edison hardware
          DiegoV_Intel

          Hello NonameUser,

           

          A "factory reset" would be re-flashing the Edison with the Yocto image. You can do it using the Flash Tool Lite that can be downloaded from the following site: IoT - Intel® Edison Board Download | Intel® Developer Zone

           

          However, you might get connection through SSH without the need of re-flashing the module. If you have configured the Wi-Fi connection before disabling the UART2, then your Edison should have an IP address after it boots. You can check what the IP address is using an Arduino sketch. Try uploading the following sketch; it should print the IP address of the Edison. If it works, then you can try accessing the Edison through SSH using the IP address printed.

           

          void setup() {
            delay(3000);
            system("configure_edison --showWiFiIP > /dev/ttyGS0");
          }
          
          void loop() {
          
          }
          

           

          If the sketch above doesn't work, the Edison might not be connected to Wi-Fi, so re-flashing the module would be necessary to restore the default settings.

           

          Regards,

          Diego.

          • 2. Re: How to restore factory settings on Intel Edison hardware
            NonameUser

            Thank you for link, I`ll try it tomorrow.

            I`m afraid that wi-fi connection is not working anymore, edison was in access point mode and after reboot I don`t see wi-fi.

            • 3. Re: How to restore factory settings on Intel Edison hardware
              DiegoV_Intel

              Hello NonameUser,

               

              If that is the case, then you can disable the AP mode with the command configure_edison --disableOneTimeSetup. Run the following sketch instead of the other one that I posted before. The AP mode should be disabled, and then the IP address should be printed.

               

              void setup() {
                delay(3000);
                system("echo 'Disabling AP mode...' > /dev/ttyGS0");
                system("configure_edison --disableOneTimeSetup > /dev/ttyGS0");
                delay(12000);
                system("echo 'AP mode disabled.' > /dev/ttyGS0");
                system("echo 'IP address:' > /dev/ttyGS0");
                system("configure_edison --showWiFiIP > /dev/ttyGS0");
              }
              
              void loop() {
              
              }
              

               

              Regards,

              Diego.

              • 4. Re: How to restore factory settings on Intel Edison hardware
                NonameUser

                I read on the forum that command "fw_setenv bootargs_console" on new yocto image causes boot problems.

                So, I could not upload these sketches. But the link to Flash Tool Lite was helpful. Thank you =)