5 Replies Latest reply on Dec 1, 2015 2:14 AM by verysch

    Wireless Adapter von a/b/g/n auf nur g umstellen in Ubuntu

    verysch

      Hallo allerseits,

       

      ich habe einen Dell Laptop mit dual band wireless ac 3160 Karte von Intel und dual boote darauf Ubuntu und Windows 8.

       

      Seit einigen Tagen habe ich einen neuen Router und mit dem habe ich einige Probleme. Die Verbindung wird zwar hergestellt, das Internet ist aber nicht zugänglich. Das ist nur auf meinem Laptop so. Kein anderes Device hat solche Probleme. Auch die LAN Verbindung an meinem Laptop funktioniert einwandfrei.

       

      Unter Windows habe ich festgestellt, dass das Problem gelöst ist, wenn ich im Netzwerkadapter die Modulation von a/b/g/n auf g ändere.

       

      Das würde ich jetzt unter Ubuntu gerne genauso machen.

       

      Ich habe

      sudo iwconfig wlan0 modu 11g

      versucht. Folgender Fehler tauchte auf:

      Error for wireless request "Set Modulation" (8B2F) :

          SET failed on device wlan0 ; Operation not supported.

      iwpriv ergab:

      eth0      no private ioctls.

       

      lo        no private ioctls.

       

      wlan0     no private ioctls.

       

      Gibt es trotzdem eine Möglichkeit die Modulationen a und b zu verbieten?

      Viele Grüße und Danke schon mal für jede Antwort!

        • 1. Re: Wireless Adapter von a/b/g/n auf nur g umstellen in Ubuntu
          jonathan_intel

          Hello verysch,

           

          We would like to let you know that this forum is supported only in english. Using an online translator we understand you have an Intel® Dual Band Wireless-AC 3160 in you Dell Laptop showing connectivity issues with your new router, for this reason, you would like to set it for 802.11g only.

           

          Here are the most relevant aspects we can provide about this matter.

           

          - You might want to check with the Router manufacturer for Firmware updates and recommended configurations.

           

          - The Linux drivers are part of the upstream Linux kernel and are available through the regular channels, distributions, or The Linux Kernel Archives. Driver development is done in the open source Linux community. Development support is only available through the open source community mailing lists. Intel does not provide support for development drivers.

           

          For Linux driver support information and links, please review the following advisory: Intel® Wi-Fi Products — Linux* Support for Intel® Wi-Fi Adapters

           

          I did a quick online check about this and noticed that the modulation can only be changed to modes supported by the driver, these modes can be shown with the "iwlist [interface] modulation" command. Here are some threads from the Ubuntu forums that may help you:

           

          Ubuntu Manpage: iwconfig - configure a wireless network interface

          Ubuntu Forums

          Ubuntu Forums

          Ubuntu Forums

           

          *NOTE: These links are being offered for your convenience and should not be viewed as an endorsement by Intel of the content, products, or services offered there.

          • 2. Re: Wireless Adapter von a/b/g/n auf nur g umstellen in Ubuntu
            verysch

            Thank you Jonathan for the quick answer and sorry I wrote in German. You did understand my problem pretty well. I have a Intel® Dual Band Wireless-AC 3160 in my Dell Laptop showing connectivity issues with your new router. No other devices have the same problem.

             

            I get a connection to the rooter but it says "limited: no Internet access".

             

            I thought from some googleing that setting the driver to 802.11g only would help. Turns out it didn't solve the problem permanently. What helps is sometimes resetting the network adapter, sometimes resetting the rooter, sometimes connection via ethermet. All of these actions only help once though (and sometimes they don't work at all). The next day I have the same issue again. Do you have any idea how to solve this?

             

            Here is some information on my system:

            the rooter is a 02 box 6431 by astoria networks

            the dell is an inspiron 5000

            I dual boot windows 8 and Ubuntu they both have the same problem.

            Any help is greatly appreciated.

            Best regards

            verysch

            • 3. Re: Wireless Adapter von a/b/g/n auf nur g umstellen in Ubuntu
              verysch

              oh and the driver version is 17.13.12.1

              • 4. Re: Wireless Adapter von a/b/g/n auf nur g umstellen in Ubuntu
                jonathan_intel

                Hello verysch,

                 

                Please apply the following actions, we will focus in Windows® 8:

                 

                - Update to the Intel® PROSet/Wireless Software and Drivers, the latest version for Windows 8* is 17.16.0.

                Downloads for Intel® Dual Band Wireless-AC 3160

                 

                - Apply the configuration mentioned in the advisory: Wireless Networking — What are the Recommended Settings for 802.11n Connectivity?

                 

                - Disable Bluetooth in your PC. This is normally done with a switch in the PC chassis, or with a key combination.

                 

                - Contact the manufacturer of the access point and make sure you have the latest firmware for it.

                 

                - Disable Wireless security/encryption in the access point and test if this helps with the problem.

                1 of 1 people found this helpful
                • 5. Re: Wireless Adapter von a/b/g/n auf nur g umstellen in Ubuntu
                  verysch

                  Thank you Jonathan.

                  It seems to have helped. So far I haven't had the problem anymore. I only strayed from the recommended settings, in the channel width selected on the router. Because I found the recommendation else where for my router to set it to 20MHz instead of 40 or auto.

                  I hope it stays this way. Thank you for the help!