3 Replies Latest reply on Nov 23, 2015 3:52 AM by mhahn

    connmanctl fails to connect to enterprise wifi?

    ivansky

      I'm still plugging away at connecting my Galileo Gen 2 board to the school's enterprise (802.1x) wifi network and still not really getting anywhere.  I have found the instructions for "WiFi access on Intel Galileo" at WiFi access on Intel® Galileo with Yocto* Linux | Intel® Developer Zone to be quite helpful. I certainly have no problems with the board connecting to my standard WPA2 network at home whenever it boots. I have installed an Intel Centrino Wireless-N 2200 PCI-E card, and I'm running what I believe is the latest IoT Linux distribution for the board.

       

      When I try to use connmanctl to set the board up to connect to the school enterprise wifi, I just get errors that suggest to me I don't know how to drive connmanctl correctly - since this command is new to me, I don't find this too surprising.  I was hoping someone could give me some guidance as to why it doesn't seem to want to even try to connect. For instance:

       

      connmanctl> services

                               wifi_001500a43360_hidden_managed_ieee8021x

          EDU                  wifi_001500a43360_454455_managed_ieee8021x

      connmanctl> agent on

      Agent registered

      connmanctl> connect wifi_001500a43360_454455_managed_ieee8021x

      Error /net/connman/service/wifi_001500a43360_454455_managed_ieee8021x: Invalid arguments

      I also tried to follow the suggestion at the bottom of the page for an enterprise network, by creating the settings file and trying to connect but I still get an error.

      connmanctl> connect EDU

      Error /net/connman/service/EDU: Method "Connect" with signature "" on interface "net.connman.Service" doesn't exist

      I'm not very familiar with connmanctl so would love some help.  I've now been trying to connect this Galileo board to the school network for over three months!  (I only visit every fortnight).

      Thanks.