5 Replies Latest reply on Dec 18, 2009 11:01 PM by Yippy

    Speed problem with X25-M only about 138 Mb/s sequential read speed with SATA-300

    Brain11

      Hello at all,

      as you can see at the thread title, i have a problem with the sequential read speed.

      My system is a Dell Vostro 1700 with 2 SATA drives.
      One of them i have changed to the X25-M... The other is a normal drive.

      Crystal Disk Info tells me, that the drive is running on SATA-300.

      System is Windows 7 64 bit.

      The System is fast in relation to the ordinary drive
      Boot time about 23 sek.
      Shutdown time about 13 sek.
      The starting time of all programmes is very fast too.
      Click and running...

      But i think there should be more read speed than only 138 mb...
      Write speed is ok. About 75 to 78 Mb/s.

      What can i do to improve the speed?
      Where should i search for the problem?

      I hope my english is good enough that you understand what i mean.

      Greetings from germany
      Brain11

        • 1. Re: Speed problem with X25-M only about 138 Mb/s sequential read speed with SATA-300
          Brain11

          OK...

          My Dell has a Feature called Flash Cache Module wich i can enable oder disable in the bios

          I have done some benchmarks with different configurations


          SATA with Flash Modul
          ---------------------------------------------------------------
          CrystalDiskMark 3.0 x64 Beta2 (C) 2007-2009 hiyohiyo
                             Crystal Dew World : http://crystalmark.info/
          ---------------------------------------------------------------

                     Sequential Read :  137.862 MB/s
                    Sequential Write :   78.328 MB/s
                   Random Read 512KB :  127.132 MB/s
                  Random Write 512KB :   62.056 MB/s
              Random Read 4KB (QD=1) :   16.006 MB/s [  3907.6 IOPS]
             Random Write 4KB (QD=1) :   21.102 MB/s [  5151.9 IOPS]
             Random Read 4KB (QD=32) :   99.109 MB/s [ 24196.5 IOPS]
            Random Write 4KB (QD=32) :   44.709 MB/s [ 10915.4 IOPS]

            Test : 500 MB [C: Used 48.9% (36.4/74.4 GB)]
            Date : 2009/12/10 15:28:41
              OS : Windows 7  [6.1 Build 7600] (x64)

           


          SATA without Flash Modul
          ---------------------------------------------------------------
          CrystalDiskMark 3.0 x64 Beta2 (C) 2007-2009 hiyohiyo
                             Crystal Dew World : http://crystalmark.info/
          ---------------------------------------------------------------

                     Sequential Read :  138.847 MB/s
                    Sequential Write :   81.792 MB/s
                   Random Read 512KB :  127.047 MB/s
                  Random Write 512KB :   71.190 MB/s
              Random Read 4KB (QD=1) :   16.419 MB/s [  4008.6 IOPS]
             Random Write 4KB (QD=1) :   28.361 MB/s [  6924.1 IOPS]
             Random Read 4KB (QD=32) :   99.634 MB/s [ 24324.8 IOPS]
            Random Write 4KB (QD=32) :   67.155 MB/s [ 16395.2 IOPS]

            Test : 500 MB [C: Used 50.4% (37.5/74.4 GB)]
            Date : 2009/12/15 0:55:38
              OS : Windows 7  [6.1 Build 7600] (x64)

           

          ATA without Flash Modul
          ---------------------------------------------------------------
          CrystalDiskMark 3.0 x64 Beta2 (C) 2007-2009 hiyohiyo
                             Crystal Dew World : http://crystalmark.info/
          ---------------------------------------------------------------

                     Sequential Read :  228.947 MB/s
                    Sequential Write :   84.494 MB/s
                   Random Read 512KB :  159.216 MB/s
                  Random Write 512KB :   74.257 MB/s
              Random Read 4KB (QD=1) :   16.879 MB/s [  4121.0 IOPS]
             Random Write 4KB (QD=1) :   35.263 MB/s [  8609.0 IOPS]
             Random Read 4KB (QD=32) :   19.982 MB/s [  4878.5 IOPS]
            Random Write 4KB (QD=32) :   51.320 MB/s [ 12529.3 IOPS]

            Test : 500 MB [C: Used 50.4% (37.5/74.4 GB)]
            Date : 2009/12/15 0:44:30
              OS : Windows 7  [6.1 Build 7600] (x64)


          it seems to be impossible to get the speed off the different modes combined into one...

           

          the fastest mode at usual use at work seems to be SATA without Flash Modul

          • 2. Re: Speed problem with X25-M only about 138 Mb/s sequential read speed with SATA-300
            ambizytl

            Do you have TRIM firmware installed, BIOS set to AHCI?

            • 3. Re: Speed problem with X25-M only about 138 Mb/s sequential read speed with SATA-300
              Brain11

              yes, i have installed the actual firmware and ahci is enabled. I have tested all modes and all combinations of modes, as you can see my crystal test results

              • 4. Re: Speed problem with X25-M only about 138 Mb/s sequential read speed with SATA-300
                ambizytl

                The sequential read speed should be at least 250, I haven't checked your other scores. Can you post a picture of the results from Crystal Disk Mark?

                • 5. Re: Speed problem with X25-M only about 138 Mb/s sequential read speed with SATA-300
                  Yippy

                  I went and changed it to MS AHCI drivers and I get 191 read speed in Crystal Disk Mark.  I've seen people hit 250 on seq though.