1 Reply Latest reply on Nov 21, 2015 9:01 AM by ivanu_intel

    Intel version too old and game requirement

    Agui

      Hey!

       

      I have just bought the new Star Wars battlefront and when I start the game, I have a black window with a message who said my intel version is too old (10.18.10.4276) and the game requier xx.xx.14.4264.

       

      When I download this version I have an error message who said that my system can't run it.

       

      I'm under Windows 8.1, my system is Intel Pentium 64 bit cpu 2117u  1.80 GHz

       

       

       

      Can you help me please?