3 Replies Latest reply on Mar 31, 2016 10:41 AM by crmakers

    Sketch.elf cannot run at system boot-up

    lurker0

      Hi,

       

      I run my Arduino program successfully on Edison + Arduino breakout board. However, I found the program cannot be invoked at system boot-up.

       

      After searching related information on internet, I understand the program is stored in /sketch/sketch.elf.  This is systemd service called clloader.service which is responsible for loading it (sketch.elf) when system is booting. I checked process list after system is up (by issuing 'ps | grep sketch').  Sketch.elf is not there.  Furthermore,  I checked clloader's status and found it reports child process termination.

       

      I also tried blink sketch which is simple example provided by arduino-Intel IDE.  The behavior is consistent.  So it is not because of my program.

      To make sure that it is not caused by anything I made previously, I tried to restore factory default and update to latest release but it did not help.

      Header 1

      root@edison:~# systemctl status clloader -l

      clloader.service - Daemon to handle arduino sketches

         Loaded: loaded (/lib/systemd/system/clloader.service; enabled)

         Active: active (running) since Fri 2015-11-13 07:43:25 UTC; 8min ago

      Main PID: 191 (launcher.sh)

         CGroup: /system.slice/clloader.service

                 ├─191 /bin/sh /opt/edison/launcher.sh

                 └─199 /opt/edison/clloader --escape --binary --zmodem --disable-timeouts

       

      Nov 13 07:43:25 edison systemd[1]: Started Daemon to handle arduino sketches.

      Nov 13 07:43:26 edison launcher.sh[191]: Opened /dev/ttyGS0 as inputOpened /dev/ttyGS0 as outputSketch child process started, pid=0202

      Nov 13 07:43:26 edison launcher.sh[191]: sigchld signal rxed.. child pid:202 terminated, go back to wait for command ...

      Nov 13 07:43:26 edison launcher.sh[191]: critical fault during select errno=4HUP or CHLDTERM Received, Change state to wait for command from host

      root@edison:~#

       

      Does anyone meet similar issue before?  Do I miss something?

       

       

      HW: edison board + Arduino breakout board

      SW: w_iot_2015.0.028  (arduino-1.5.3-Intel.1.0.4)   latest release