4 Replies Latest reply on Dec 4, 2015 4:26 PM by CMata_Intel

    Web server errors !

    Hathout

      I'm trying to run the intel xdk IoT edtion which is a simple web server, i couldn't run it using the xdx because if found a lot of errors, so i copied the directory and transfered it to the Galileo board using scp and it was OK, then i ran the file main.js ,but i found many errors!

      Any HELP ?

      Baam.png

        • 1. Re: Web server errors !
          PabloM_Intel

          Hi Hathout,

           

          • Could you please tell us which image you are using?
          • The uClibc or eglibc image? Which version of the XDK are you using?
          • Also, can you provide us an image of the message log that you’re getting in the XDK when running the code?
          • Can you share the script that you’re using?

           

          According to the error in the screenshot, you’re calling a HTML script from a nonexistent folder. Did you check that the path is the correct one?

           

          Regards,

          PabloM_Intel

          • 2. Re: Web server errors !
            Hathout

            First of all thank you for replaying PabloM_Intel

            - IoT devkit image from intel

            - eglibc     / intel xdk IoT edition 2571

            - First of all i do not be able to find my board then i always connect it manually and punch of errors appears with each example

            1.png

            - This is the code

            2.png

             

            The screenshot above is the error which i got after i copied this project directory from the xdk path to the board, And yes i noticed this problem and i solved it ,but i found some other problems

            3.png

            • 3. Re: Web server errors !
              PabloM_Intel

              Hi Hathout,

               

              Did you make sure that your Galileo is in the same network/subnet as your computer? The one running the XDK. Some firewalls can also prevent your computer from auto-connect to your board. Regarding the XDK errors that you’re getting, some of those “JSHint Problems” are actually wrong and can be ignored (e.g: JSHint doesn’t recognize ‘require’), I would suggest you to keep an eye on syntax errors.

              In the last picture that you shared, I think you miss a dot. Instead of writing main.js, you wrote mainjs. Please correct me if I’m wrong. The path seems to be correct now.

               

              Regards,

              PabloM_Intel

              • 4. Re: Web server errors !
                CMata_Intel

                Hi Hathout,

                 

                Do you have updates on this?  Have you been able to run your code?

                When you use the XDK, you should be able to see a folder on the board with the main.js and package.json (/home/root/.node_app_slot), could you post the source of the code? We could try it too.

                Also, could you run the command opkg list-installed xdk-daemon?

                Are you also having problems while running the examples on the XDK?

                 

                Regards,

                Charlie