6 Replies Latest reply on Nov 18, 2015 11:42 PM by Sandy_Intel

    Unable to update i350-T4 NIC flash.

    IamGimli

      I've been trying to update the flash on an Intel i350-T4 NIC I got off Amazon but for some reason bootutil won't let me.

       

      First when I just run bootutil it show all four ports on the card to be in "FLASH not present" mode.

       

      When I run "bootutil -nic=1 -fe" it says the command has succeeded and to reboot to enable flash. After a reboot nothing has changed and trying to update the flash with "bootutil -nic=1 -up=pxe -file=bootimg.flb" results in a "Flash is not enabled on port 1" error (using the Intel bootutil) or an "Adaptor port is not bootable on port 1" error is using an IBM or Dell version of bootutil.

       

      Trying to execute "bootutil -nic=1 -bootenable=pxe" with either Dell or IBM bootutil gives the same "Adaptor port is not bootable on port 1" error. Using the Intel bootutil for the same commands gives a "Found discrete ROM in the flash for NIC 1" error.

       

      I'm at a loss as to how to update the flash. Tried to get the Cisco version of bootutil to see if that worked any better but the Cisco support site is a mess and won't let me login to download their tools.

       

      Does anybody have any suggestion on any other version of bootutil to use or anything else to try to update the flash on this card? I tried to contact the Amazon vendor to find out exactly what system manufacturer's server this card was taken out of but haven't had any luck yet.