1 Reply Latest reply on Nov 9, 2015 11:33 PM by Vincenze

    I2C Device not detected

    ptolemy

      I think this is quite a simple problem but I've had a bit of trouble with it (I'm a beginner with it really).

       

      I'm trying to connect a BMP180 Barometer to the Intel Edison through the Mini Breakout board using I2C (I don't have an Arduino board). I've started by wiring up the I2C connection.

      I tried using I2C1, by connecting SDA and SCL lines to the chip. And of course with 3.3V and GND aswell. When I try detecting this with 'i2cdetect -y -r 1', No addresses appear whatsoever. Running 'i2cdetect -l' goes fine and lists 1-7 i2cs.

      So I have alternatively added Pull-up (220 ohm) resistors to both SCL and SDA, with no change. I've also tried I2C6, but I find the Edison crashes when detecting (Although this is a slight problem; its a separate one which I don't mind if I can get I2C1 working instead).

      I am confused why my device is not appearing, and what I need to do detect it.

       

      When this is working I will then attempt to use the UPM libraries for this, which I have tried, but am a bit confused on how to. I've copied the library c++ files (.h and .cxx) and copied the example into the same folder. Then I've tried compiling this with 'g++ bmp.cxx -lmraa'. This tells me 'Result in namespace does not have a type' (with or without -lmraa). Reading around I think its something to do with linkage? Although I've not much clue.

      How should I compile this correctly.

       

      Any help accepted.
      Thanks.