3 Replies Latest reply on Nov 15, 2015 4:04 PM by ansst5

    SD boot on Galileo Gen 2 problem

    ansst5

      I am new to the Galileo Gen 2 and have been unsuccessful at booting from an SD card.  I performed the following steps.

      1. Downloaded iot-devkit-201510010757-mmcblkp0-galileo.direct.xz

      2. Used 7-ZIP to unpack resulting in iot-devkit-201510010757-mmcblkp0-galileo.direct

      3. Used win32-diskimager to load this onto an 8gb sd card. Tried both Sandisk and PNY SD cards.

      4. Placed SD card in the Galileo

      5. Removed the usb cable to my laptop (Windows 7)

      6. Removed the serial cable

      7. Plugged in the Galileo power cable

      8. After a few seconds, plugged in the serial cable and started Putty and logged onto terminal

      9. During the boot process,       No "boot/grub/grub.conf" file from usb or sd device was displayed.

          After the system was running, 201410101603 resulted after cat /etc/version was entered.

          This indicated that the onboard system, not the SD system is running.

       

      I have tried several times with no luck.

       

      I must be missing some critical step.  Any help would be greatly appreciated.

       

      Thank You in advance.

       

      Also updated firmware to 1.0.4 on galileo

        • 1. Re: SD boot on Galileo Gen 2 problem
          CMata_Intel

          Hi ansst5,

           

          After you upload the image with win32-diskImager, what are the files you are able to see in the SD card?

          Did you use another image version before?

          Did you update the firmware of the board? Firmware Updater Tool

           

          Regards,

          Charlie

          • 2. Re: SD boot on Galileo Gen 2 problem
            CMata_Intel

            Hi ansst5,


            Do you have updates on this? Have you been able to boot from the SD card?


            Regards,

            Charlie

            1 of 1 people found this helpful
            • 3. Re: SD boot on Galileo Gen 2 problem
              ansst5

              Hi Charlie,

              Thanks for you speedy reply. After working with the board for quite a while, I noticed something foreign sticking to the bottom of the board, packing material or something. Very small. I removed it with my fingernail and tried booting from the SD card again. This time it worked fine! The foreign material (speck) must have been providing a low impedance path preventing some circuit from functioning.  Since then I have been moving along starting to work with the Galileo, transferring python scripts with WinSCP  and calling them from Arduino sketches and ssh using putty.  Again, thank you for you speedy reply, it was greatly appreciated.

               

              Regards,

              ansst5