4 Replies Latest reply on Nov 15, 2015 6:03 AM by gabrielw6

    Intel Galileo Gen 2 with no Serial connection and SD Card problem.

    gabrielw6

      Hi all,

      I'm with some Galileo Gen 2 boards, and I'm having some problems to interact with them. First of all, I couldn't establish a Serial terminal connection with two of the boards I tried, where I saw what was in Linux Tutorial For Intel® Galileo Gen 2, but no success. In Ubuntu, when I type "picocom -b 115200 /dev/ttyACM0", it responds with "Terminal ready", but the cursor is still and I can't type anything or send any commands. When I upload a sketch via the Arduino IDE which outputs to Serial, if I picocom again to the board I see the output on either Terminal or Serial Monitor. Anyway, in order to try to have command-line access to the board, I made a simple sketch to telnet to it:

      void setup() {
           system("ifconfig eth0 10.0.0.2 netmask 255.255.255.0 up");
           system("telnetd -l /bin/sh");
           system("ifconfig > /dev/ttyGS0");
      }
      
      void loop() {}
      

      In this setup, using an Ethernet cable I am able to telnet and send commands to it. Although this seems as a partial solution, I found it weird to have this different behavior from what is described on the guide in two boards.

      The next thing, though, happens to be I want to use a Wifi card on the board, and thus I need to use an SD card Linux Image. When I put any of the images(either the basic SD image or IoT image) on the card, the board behaves very weirdly. When I turn the board on with the SD card connected and I connect it to my computer through the USB cable, on the first time my computer recognized the ttyACM0 device, as the Arduino IDE did. When I tried to upload the same sketch from above, I got a timeout error in the Arduino IDE. Thus, I'm not able to access the terminal when I connect an SD card to the boards.

       

      These issues occurred on two brand new boards. I have other 8 also brand new, but just in case the problem is my PC I'm asking you guys first. Thanks in advance.