4 Replies Latest reply on Nov 14, 2015 5:08 AM by cer1991

    Problem when building 2.1 image

    cer1991

      Hello,

      when I bulid the newest image for edison(2.1),some problem happens:

      Currently 2 running tasks (2299 of 3757):
      0: xdk-daemon-0.0.35-r0 do_compile (pid 28711)
      1: iotkit-comm-js-0.2.0-r0 do_compile (pid 28712)
      
      

      the process was blocked in this tasks and I wait a very long time but nothing happens

      who can help me fix it?

      Thank you very much.

        • 1. Re: Problem when building 2.1 image
          CMata_Intel

          Hi cer1991,

           

          The building process takes a lot of time so if there is no activity in the screen could be normal.  Some questions:

          1. Which OS are you using on your PC?
          2. Are you doing changes to the image?
          3. Do you have a stable Internet connection?
          4. Did you get errors after running the setup.sh script?
          5. Did you stop the process or did you receive an error message?
          6. Are you using this BSP Guide and this source files

           

          Regards,

          Charlie

          • 2. Re: Problem when building 2.1 image
            cer1991

            Hi,@CMata_intel

             

            1.Ubuntu 14.04(VMware)

            2.No

            3.I think yes,but I am not sure.Because I am in China and I use VPN to connect Internet.

            4.No

            5.Sometimes it will send error messages but most of them are like 'can not fetch xxxxxx' and when the building is stoped,I will change other VPN to fix the error.

            6.Yes,of course.

             

            At today,I use another PC to build the image.

            I get this problem as below:

            WARNING: Failed to fetch URL ftp://ftp.debian.org/debian/pool/main/d/dpkg/dpkg_1.17.4.tar.xz, attempting MIRRORS if available
            WARNING: Failed to fetch URL http://ftp.de.debian.org/debian/pool/main/m/mklibs/mklibs_0.1.39.tar.xz, attempting MIRRORS if available
            WARNING: Failed to fetch URL ftp://ftp.berlios.de/pub/cdrecord/alpha/cdrtools-3.01a20.tar.bz2, attempting MIRRORS if available
            WARNING: QA Issue: battery-voltage rdepends on libsystemd, but it isn't a build dependency? [build-deps]
            WARNING: QA Issue: iotkit-agent requires /bin/bash, but no providers in its RDEPENDS [file-rdeps]
            WARNING: QA Issue: pulseaudio-module-console-kit rdepends on consolekit, but it isn't a build dependency? [build-deps]
            WARNING: QA Issue: systemd-kernel-install requires /bin/bash, but no providers in its RDEPENDS [file-rdeps]
            WARNING: QA Issue: post-install requires /bin/bash, but no providers in its RDEPENDS [file-rdeps]
            WARNING: QA Issue: wpa-supplicant-passphrase rdepends on libcrypto, but it isn't a build dependency? [build-deps]
            WARNING: QA Issue: wpa-supplicant rdepends on libcrypto, but it isn't a build dependency? [build-deps]
            WARNING: QA Issue: wpa-supplicant rdepends on libssl, but it isn't a build dependency? [build-deps]
            Currently 2 running tasks (3739 of 3757):
            0: xdk-daemon-0.0.35-r0 do_compile (pid 26662)
            1: iotkit-comm-js-0.2.0-r0 do_compile (pid 26663)
            

            The process is stoped at there again.

            Are these warnings ok?Do I need to solve them?

            Can I use 'ctrl+c to' kill the process in this case?

            • 3. Re: Problem when building 2.1 image
              CMata_Intel

              Hi cer1991,

               

              The warnings you are having are while fetching the files and packages. This could mean that the links are not working but as they are warnings, your image shouldn’t be seriously affected. If you get errors while building the image I suggest you to check all the errors and see which link is the one that is failing.

              The behavior you are having could be due to the resources you have assigned to your virtual machine. I suggest you to give more space and memory to the virtual machine.

               

              Kind regards,

              Charlie

              • 4. Re: Problem when building 2.1 image
                cer1991

                you are right!

                Thank you!