11 Replies Latest reply on May 4, 2011 4:46 AM by

    help: DG41TY - No display.


      Hi, every one. I'm new here in Intel discussion communities, hope that I'm in the right thread and hoping Intel comm can solve my problem.




      I have 2 Intel Desktop Board - DG41TY, and it was no warranty for now.





      Mother Board     :      Intel DG41TY

      CPU          :     Intel Core 2 Quad 2.33 GHz Intel Q8200

      RAM          :      KVR800D2N6/2G 2x2(4GB)

      OS's          :      XP

      POWER      :     (2 x 12 pin) and (2 x 2 pin)

      Problem     :

      There is no display and no beep. I try to clear CMOS jumper to clear the cmos settings, and still no display or any activity but it has a power. Processor is OK. RAM is OK.




      Pls. Any idea on how to solve this problem. Power is good, RAM is good, CPU is good.









        • 1. Re: help: DG41TY - No display.

          Hi there,


          Does your system boot into BIOS? If no, then


          If both of these components meet the requirements, then continue to the next steps.


          1. Remove all the memory
              Does the board issue any beeps? If yes, how many?


          2. Test the board out of the chassis. Use only one memory module for testing purposes.

              - Put back the memory module and try to boot the board by short-circuiting the pin for power on, check the guide to refer to which pins. Dont use the front panel to switch on the board.


          3. If still there is no boot, switch the bios jumper to Maintenance/Configuration Mode.



          4. Try with another memory module.


          5. If the system manages to boot, then try a bios recovery using a formatted USB media.


          Instructions for Recovery BIOS Updates
          In the unlikely event that a BIOS update is interrupted, it is possible the BIOS may be left in an unusable state. The recovery process requires the chassis to be opened to remove the onboard BIOS Configuration Jumper.
          WARNING: This process is intended to be performed by a trained technician.
          Recovery with Formatted USB Stick


          1. Copy the recovery file (*.bio) to a formatted usb disk.
          2. Place the usb disk in the target system.
          3. Shut down the system and unplug AC power.
          4. Open the chassis and remove the BIOS Configuration Jumper. See the Technical Product Specification for details including the location of this jumper.
          5. Power the system on.
          6. Wait 2-5 minutes for the update to complete. When the usb drive LED is lit, the system is copying the recovery code into the FLASH device.
          7. System will either turn off when the recovery process is completed or it will prompt you to turn off the system.
          8. Remove usb disk
          9. Replace the BIOS Configuration Jumper.
          10. Restart system.


          Note: these can be found on:
          Website: http://downloadmirror.intel.com/17197/eng/BIOS%20Update%20Readme.pdf
          Page 3


          The latest bios is Version 0033.


          If this does not work, and all the board requirements are met, the board may be damaged now.



          • 2. Re: help: DG41TY - No display.

            One more thing.


            Try another module which is on the list:



            I remember an issue with the one that you are using.

            • 3. Re: help: DG41TY - No display.

              By the way, this is the test I've done.


              1. I'd already test the RAM each module, but nothing happen.

              2. I remove the RAM and power ON the board, there is no activity or any beep.

              3. I remove the battery and power ON, then after 10 secs. on power mode w/ out the battery, I put it back the battery and try to boot, but still nothing happens.

              4. I try also once put into maintenance/configuration cmos jumper (jumper 2,3 pins.) then it boot, it goes to normal. But after 2 days the problem goes back.


              This are the test I've already done.


              Any idea if ever I skipped some trouble shooting on mother board?


              Thanks for immidiate respond Sir.


              Message was edited by: Anthony Labrador

              • 4. Re: help: DG41TY - No display.

                Hello Anthony,


                Firstly, dont be formal here. There is no sir here.


                Anyway, when the system goes into maintenance mode, it should not continue to normal boot. It goes into the bios maintenance mode without pressing F2 to go into the bios.


                Now if there is no beep without memory, it can be board or cpu processor.


                Do you have another compatible CPU to test?


                All the best,


                Kind Regards,



                • 5. Re: help: DG41TY - No display.

                  Hi Aryan,

                  I am "Intelligent", a new member. I was reading  this discussion because I too have a DG41TY motherboard. Recently bought. I agree with the advice of testing the motherboard outside the computer chassis. This is a commonly problem in slightly older computers. But sometimes while assembling new computers people often forget to use those small brass type supports that keep motherboard from shorting with the cabinet. This can sometimes result is serious damage which is completely avoidable. But if the motherboard or the processor is defective then no one can do anything.


                  Well I have a question of my own to ask you. I wanted to use my old Dax internal modem on the standard PCI slot. The problem is it conflicts with the onboard lan IRQ. The following 3 items 1) Intel expresss chipset 2) onboard LAN 3)my Dax internal modem all show the IRQ 17 in Windows XP sp 3. I tried to find out the PCI IRQ setting in BIOS but it dosent show any. There is no manual provided by Intel in the box that I bought. Can you help me separate the IRQ? How do I do it in the BIOS? Or is there another way?


                  Thanks in advance


                  • 6. Re: help: DG41TY - No display.

                    Hi Anthony,


                    Did you solve the problem? Keep posting.



                    • 7. Re: help: DG41TY - No display.

                      I did not test already. coz its buisy in my work. I will post here after some fix and test.


                      Thank you.

                      • 8. Re: help: DG41TY - No display.

                        Yup the motherboard is damaged, and i test all the posibility issue.


                        Thanks very much for the help....


                        MATSALAM \m/

                        • 9. Re: help: DG41TY - No display.

                          I have the same problem with my DG41TY. Just in my case it did work for a couple of months, and now it stopped.

                          I get no beeps, not with the memory, and not without it. I have no display. I get nothing. Just the fans are working fine.

                          I also tried the BIOS recovery procedure but got nowhere.

                          Does that mean that my motherboard is broken?

                          • 10. Re: help: DG41TY - No display.

                            call Intel Customer Support for Warranty Support

                            • 11. No display.

                              Dear Sir,

                                     My Intel Desktop board DG41TY, (Sr. No. AZTY902005BM AA E47335-203).There is No Display and No Beep. I try to clear CMOS jumper to clear the  cmos settings, and still no display or any activity but it has a power.  Processor is OK. RAM is OK.

                              themumbai ..... I think its under warranty, So  please help me out and inform