2 Replies Latest reply on Nov 2, 2015 11:28 AM by s89

    Wi-Fi and Bluetooth disappeared, can't upload firmware

    s89

      Today after rebooting my Edison, I can't access the Wi-Fi and Bluetooth interfaces anymore, and my attempts to reinstall the firmware also fail. Earlier today I have tried to make an external Bluetooth dongle work on my Edison over the OTG port using a custom-compiled btusb kernel module. Possibly something broke during that attempt, hopefully only software-wise.

       

      Symptoms:

      • ifconfig doesn't show wlan0 or usb0, while it previously did.
      • After `rfkill unblock bluetooth`, hciconfig doesn't show any devices, while it previously did.
      • When connecting to my PC using the SparkFun guide, no filesystem comes up and the Intel installer also doesn't recognize the board. I have tried both OS X El Capitan and Windows 10. I'm not sure whether it worked previously on these versions, maybe it is also an issue with the OS versions being too new.

       

      How can I get my Edison board back to factory settings, or proceed in finding out what's wrong?