6 Replies Latest reply on Dec 2, 2009 2:33 PM by ohdannyboy

    "Error reading from drive A" during X-25 M firmware update?

    Alftoo

      My system includes: Asus P7P55D-PRO motherboard, Intel X25-M 80GB 34nm SSD, Samsung SH-S223L SATA CD-burner.

       

      Tried updating to the brand new firmware with TRIM support. After changing BIOS-settings to use IDE Compatibility mode instead of ACHI, I got the firmware updater to recognize the SSD. However, after answering yes to all the questions, the program went silent for several minutes, and then blurted out the following error:

       

      02122009637.jpg

       

      Tried (R)etry a couple of times before hitting (A)bort and finally after some more (A)borting, was presented with a simple command prompt (">").

       

      I thought there was something wrong with the CD, so I reburned the ISO image and booted it again. This time it claimed the firmware was already installed. Intel Matrix Storage concures, at least it shows the correct Firmware number for the new version and everything seems to work as usual. Also, when Windows first booted after the attempted update, it said something like "A restart is required to make these changes"; could this mean it detected TRIM capability and enabled it?


      Looks like the update did work(?), but the output telling about it didn't. Anyone have any explanations for the behaviour? Some thoughts:

      • could it be related to using a SATA DVD-burner (instead of plain vanilla IDE)?
      • could it be related to using a re-writable (CD-RW) disk instead of CD-R (which would be odd, as FirstDOS and the update utility seemed to start normally)

       

      Is there any way to check that the actual firmware (as opposed to some text string reserved for the version number) was updated? Did anybody with similar ASUS mainboards and SATA DVD-burners manage to update without hitches, and how was your BIOS configured with regards to AHCI vs IDE Compatibility vs IDE Enhanced?

       

      Best regards,

      Alftoo