2 Replies Latest reply on Nov 2, 2015 6:53 AM by xthunderheartx

    Wifi set to autoconnect but doesn't

    xthunderheartx

      Hey mhahn et. al., I'm having issues getting wifi to autoconnect in multiple configs/environments.  I have good settings I think:

       

      root@Garviel:~# cat /var/lib/connman/wifi_685d43256912_4d794c6974746c6552656454726163746f72_managed_psk/settings

      [wifi_685d43256912_4d794c6974746c6552656454726163746f72_managed_psk]

      Name=<MYLITTLEREDNETWORK>

      SSID=4d794c6974746c6552656454726163746f72

      Frequency=2412

      Favorite=true

      AutoConnect=true

      Modified=2015-11-01T01:48:57.431143Z

      Passphrase=<MYLITTLEREDPASSPHRASE>

      IPv4.method=dhcp

      IPv4.DHCP.LastAddress=192.168.0.155

      IPv6.method=auto

      IPv6.privacy=disabled

      IPv6.DHCP.DUID=000100011d558608685d43256912

      Failure=connect-failed

       

      But it will not connect automajikly.  I can connect manually but after a bit the wifi drops.  Hardware is this:

       

      01:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)

       

      Same issue essentially on another target in a different lab with an open network:

       

      root@galileo:~# cat /var/lib/connman/wifi_6480991c6a78_6a6c656e67656c_managed_none/settings

      [wifi_6480991c6a78_6a6c656e67656c_managed_none]

      Name=<VENGEFUL_SPIRIT>

      SSID=6a6c656e67656c

      Frequency=2462

      Favorite=true

      AutoConnect=true

      Modified=2015-11-01T01:17:28.061899Z

      IPv4.method=dhcp

      IPv6.method=auto

      IPv6.privacy=disabled

      IPv4.DHCP.LastAddress=192.168.1.142

      Failure=connect-failed

       

      with this hardware:

       

      01:00.0 Network controller: Intel Corporation Centrino Advanced-N + WiMAX 6250 [Kilmer Peak] (rev 5e)

       

      Same behavior.  Any help very much appreciated!!

       

      Dallas

        • 1. Re: Wifi set to autoconnect but doesn't
          mhahn

          xthunderheartx - not sure I can answer. Some hints:

          the auto-connect is temporarily ignored in connman if there is some lower level disconnect or connection failure error. This way connman will not try to re-connect to AP that is constantly failing.

          User is able to manually re-connect the AP and if the connection succeeds, then auto-connect is enabled again.

          • 2. Re: Wifi set to autoconnect but doesn't
            xthunderheartx

            Are you kiddin'? That absolutely answers the question!  That has to be what is happening.  Of course it brings up another question which is can connman's behavior be changed to always try to autoconnect.  In our application the Galileo has now wired Ethernet (the RJ45 is literally removed), no console (we use ttys1 to talk to a PIC, ttyS0 to talk to a modem) and lives in an unattended environment.  Manual intervention is not really an option.

             

            While I have you can you tell me if there is a new image for IOTDK image in the works?  I notice there is a 2.0 repo on the site but the released image is 1.5 right?  I have been hoping for some package upgrades, though it looks like most at still at the 1.5 versions. Connman is one I was hoping for as I couldn't get Wifi Direct (p2p) working and have to resort to plain old tethering.  Plus you tell people on other channels like irc:#connman you are running 1.25 and their immediate response is "upgrade".

             

            Thanks for your help Matthias!