7 Replies Latest reply on Nov 11, 2015 11:50 AM by mikec_intel

    Intel NUC NUC5i3RYK display port issues

    JPR86

      Bought this about 2 months ago. All was going well, fast, small footprint, easy to build... Then after about 30 days, my 2nd display hooked up to my display port started to disappear.

      Running windows 10, looked in the device manager and it showed 2 monitors, but the display port was just blank. After several reboots and pulling the display port plug and reconnecting, it would finally come back on. Well, this has happened several times in the past month and now... nothing. It does not come back at all.

      Any suggestions?

       

      I happened to have a USB 3.0 to HDMI converter so I am using that to avoid the erratic behavior of the display port. But I would like to know if this is a known issue or if I may have a defective unit.

        • 1. Re: Intel NUC NUC5i3RYK display port issues
          jasonNUC

          Hi JPR86,

           

          First things first:

          • What type of cable are you using?  (mini DisplayPort to DisplayPort?  Mini DP to HDMI?  HDMI cable with mini DP adapter?)
          • Have you tried another cable.  I've seen issues like this on other NUCs and it's usually the cable, not the NUC.
          • You're running Windows 10. Have you updated to the latest video drivers?

           

          Thanks.

           

          Jason

          • 2. Re: Intel NUC NUC5i3RYK display port issues
            JPR86

            Cable matters Mini display port to HDMI (thunderbolt port compatible, if that matters). Latest driver, 20.19.15.4300..

            Never crossed my mind it could just be a faulty cable. I will try a different brand mini display port to HDMI cable and report back if that stops it.

             

            As an aside, I tried plugging the mini display port back into the monitor this morning and it works just fine now. Sporadic issues drive me crazy.

            • 3. Re: Intel NUC NUC5i3RYK display port issues
              jasonNUC

              Yep, I hear ya.  I was frustrated beyond belief with one of my NUCs.  I was certain it was a faulty unit because the screen would blank out and come back, and sometimes shake. I tried a different cable...same thing.  Then, by chance I happened to try a third cable and it worked perfectly.  I don't think it's necessarily just the fault of the cable. It seems the NUCs can be highly sensitive to the cables.  So a cable that works fine on one system may not work at all on another.  I read up on it at the time and it seems the HDMI standard may play a role.  I've never seen an issue with a mini DP to DP cable on the NUCs.  It's always when you go from mini HDMI to HDMI, or mini DP to HDMI.  At least in my experience.

               

              I've actually had great success with the cheap mini DP to HDMI adapters (from ebay) and a standard HDMI cable.

              • 4. Re: Intel NUC NUC5i3RYK display port issues
                JPR86

                Thanks, Jason. Right before you replied, I remembered I had one of those Mini DP to HDMI adapters. I just hooked it up with an HDMI cable and it is working fine. I will report back in a few days if that took care of the issue.

                • 5. Re: Intel NUC NUC5i3RYK display port issues
                  mikec_intel

                  Hi JPR86,

                   

                  Are you still having issues with the NUC 5i3RYK?

                   

                  Regards,
                  Mike C

                  • 6. Re: Intel NUC NUC5i3RYK display port issues
                    JPR86

                    Mikec

                    No issues since switching to the DP to HDMI adapter and a standard HDMI cable.

                    So, it appears the DP to HDMI cable was either bad or incompatible.

                     

                    Thanks for your help! I just would have never imagined a new cable could be the issue.

                    • 7. Re: Intel NUC NUC5i3RYK display port issues
                      mikec_intel

                      Hi JPR86,

                       

                      Thank you for your feedback. I am glad your system is working properly.

                       

                      Regards,
                      Mike C