12 Replies Latest reply on Dec 4, 2009 9:53 AM by ambizytl

    Updated Firmware released

    afrosty

      Hey everyone,

       

      If you haven't seen this yet in the announcements or in the replies:

      Intel has released a new firmware (02HD) and firmware update tool (version 1.5) to fix the issue with the firmware update process on 34nm (G2) Intel® X25-M SSDs (80GB and 160GB).

      Intel recommends that end users Download this firmware update tool and upgrade your SSD

              This new firmware provides Trim support (on 80GB and 160GB) and better sequential write performance (on 160GB)

              If you experience any issues during the upgrade process contact Intel Customer Support

       

      @ xout: Thanks for getting the word out.

       

      rgds,

      alan

      NAND Solutions Group

        • 1. Re: Updated Firmware released
          ambizytl

          For those of us who successfully installed 02HA, should we update to 02HD? Are there any improvements or any reason to update to 02HD?

          • 2. Re: Updated Firmware released
            ambizytl

            Can I get an answer to my question above?

            • 3. Re: Updated Firmware released
              rired48

              I have found this process confusing. Is the upgrade and new tool safe to use? And, I cannot find the version numbers on my SSD...here are my 'numbers' from the Intel 160gig SSD I have:

               

              mfg part: SSDSA2MH160G2C1

              Version: E64509 -307(on box)

              Pack date: 7aug09

               

              So, should I do the upgrade??

               

              Help, someone...   Thanks

              Brian in RI/USA

              bbtennis1@cox.net

              • 4. Re: Updated Firmware released
                Fernando

                ambizytl schrieb:

                 

                For those of us who successfully installed 02HA, should we update to 02HD? Are there any improvements or any reason to update to 02HD?

                I have done the update from 02HA to 02HD and I really regret it.

                With the newer firmware the performance of my 2x160 GB SSD RAID0 system dropped considerably.

                The benchmark comparison between both firmware versions have been published by me here:

                http://www.computerbase.de/forum/showpost.php?p=7011366&postcount=25

                 

                Regards

                Fernando

                • 5. Re: Updated Firmware released
                  ambizytl

                  If you didn't update the last firmware, 02HA, then you should update to new firmware but read the readme first. Is it safe to upgrade? There is only one way to know.

                   

                  You can check your present firmware version by going to Device Manager, double-click the disk, click Details, select Hardware Ids from drop-down menu and see your firmware.

                  • 6. Re: Updated Firmware released
                    ambizytl

                    That seems very odd. Try running the test again with 02HD and report here what you get. Sometimes the test can give varying results. Have you used AS SSD to benchmark your SSD?

                    • 7. Re: Updated Firmware released
                      rired48

                      This is the info listed in device manager:

                      "IDE/DiskINTEL_SSDSA2M160G2GC______2CV102G9"

                       

                      So, which firmware do I have, and do I need to update?

                       

                      Thanks for your patience with me...

                       

                      Brian

                      • 8. Re: Updated Firmware released
                        Dverez

                        This is Your Firmware with blue colour: "IDE/DiskINTEL_SSDSA2M160G2GC______2CV102G9"

                         

                        So recommended to upgrade to the latest firmware: 02HD

                        • 9. Re: Updated Firmware released
                          rired48

                          Thanks so much.

                           

                          So, what is the general consensus here on this issue...   is it worth the chance to upgrade the firmware? With the horror stories I have read about, I am afraid to do it to gain how much in performance? Or, does the firmware upgrade lessen the chances for this over-time 'data-degradation' we read about??

                          • 10. Re: Updated Firmware released
                            Dverez

                            The new firmwares are all about to make the SSDs better and faster. I think most of the time the users are not following Intel`s instructions that`s why they have problems. If you`re using Win7 you can get the benefit of TRIM. It keeps running your SSD as it was brand new this new firmware is all about. With the old firmware your SSD will be slower by the time, it happens with all the SSDs around the world.

                            So you decide to upgrade or not.

                            • 11. Re: Updated Firmware released
                              Fernando

                              ambizytl schrieb:

                               

                              That seems very odd. Try running the test again with 02HD and report here what you get. Sometimes the test can give varying results. Have you used AS SSD to benchmark your SSD?

                              Yes I have used the AS SSD and the CrystalDiskMark benchmark tests and all of them show lower speeds since I have flashed the 02HD firmware.

                              It seems to me, that Intel spent more attention to the security than to the performance, when they developed the new firmware version.

                              • 12. Re: Updated Firmware released
                                ambizytl

                                KInd of hard to believe the new firmware causes a decrease in performance. I have not updated my 02HA and after reading your post, I don't intend to. Still, I find it difficult to understand how performance would be hindered by new firmware.

                                 

                                Are you using msahci driver and BIOS set to AHCI?

                                 

                                I just re-read your other post and see you are doing RAID 0--then that is the problem.