0 Replies Latest reply on Oct 29, 2015 4:12 PM by NCU-Mize

    NUC 5i3RYH: Can´t get ACPI-Wakeup with Linux to run

    NCU-Mize

      I try to automatically set the Wakeup time on my NUC 5i3RYH with ACPI-Wakeup.

       

      Manual sertting the wakeup-time in BIOS does work reliable (with actual BIOS 350 RYBDWi35.86A from August 2015), but I cant´get it to run, to set the Wakeup time automatically ... (for HTPC purposes this is neccessary). Test´s with older Linux Versions 3.16 / 3.19 as with newest Linux 4.2 Releases and with several BIOS Settings hadn´t been succesful

       

        -  Can anybody tell me, that this should work (that he is using ACPI-Wakeup in conjunction with NUC 5i3RYH and actual BIOS 350)?

        -  Which BIOS Settings should I choose, to get this to run?

        -  Are there Jumper on the Mainboard available, to disable ErP Mode (specific Power Safe Mode, required in Europa) - which I was told in a forum?

       

      When I write wakeuptime with a ACPI-testscript (see below), the displayed wakeup time displayed with cat /proc/sriver/rtc is correct, but the system doesn´t wake up.

      Additionally I can neither see that this values are written into RTC Registers from Realtime Clock (after Manual PowerOn), if in BIOS "Wakeon from RTC from S5" is activated or not ...

       

        DEV=/sys/class/rtc/rtc0/wakealarm

        nextboot=`date --date "now +180 seconds" "+%s"`

        echo 0 > $DEV

        echo $nextboot > $DEV   # Some Mainboards need this one time,

        echo $nextboot > $DEV   # Some Mainboards need this 2nd time.

        cat /proc/driver/rtc

       

      I would appreciate any help ...

       

      with regards,

      Michael 

       

       

      p.s.

       

      It seems, it´s really important for Linux having the RTC running in UTC (even I didn´t believe that).

      After switching to UTC (hwclock --systohc --utc) the script above brought an error message (because of writing wakeuptime 2nd time fails), but wakeup did work correctly.

      In BIOS WakeUpOnRtc was disabled, when using ACPI-Wakeup.

       

      Problem is solved.

       

      with regards,
      Michael