8 Replies Latest reply on Nov 12, 2015 12:58 PM by rguevara

    audio issues when not using Unity

    jpcarey

      Has anyone experienced audio issues when not using Unity? I tried both Gnome3 desktop, gnome session, and i3.  All of them have the same issue - audio plays for about 1-2 seconds, and pauses / hangs.  If you then do something that will cause the CPU to spike up from idle (drag your browser around, start a process, etc) - the audio will pick up from where it hung - and play until the system goes idle again. ('$ aplay /usr/share/sounds/alsa/Front_Center.wav')

       

      I don't have an official Ubuntu/Linux stick to try this on, as I purchased a couple Windows based version (STCK1A32WFC) due to needing more memory. I installed the official Ubuntu 14.04 image, and used Ian Morrison's linuxium-z3735f-patch.sh.  I have tested against three different compute sticks with the same results.

       

      I did notice that audio works in the standalone Kodi shell*. The anomaly I ran into here was that if you change the resolution - audio will stop working.  I had to logout -> login to Unity -> launch 'unity-control-center' and click the audio 'test speaker' a couple times before audio started to work again.  Once it had, I was able to switch back over to the standalone Kodi shell.

       

      Also tried Ubuntu 15.10 last night (was hoping the newer kernel would have some better baytrail support). I was able to get Wifi working (hadess/rtl8723bs · GitHub), but no audio.