6 Replies Latest reply on Oct 29, 2015 2:33 AM by GiuseppePegasus

    Edison in damaged?

    GiuseppePegasus

      Hi guys,

       

      I bought 2 Intel Edison. I used the first Edison, I assembled it on the Arduino board. I read the toturial https://software.intel.com/en-us/get-started-edison-windows-step1.

      It seems ok: connecting the board with 2 usb-miniusb cables, my pc recognize the Edison, terminal connection were possible.

      But after some times Edison isn't recognized from my pc and it is not possible to connect via Putty.

      The same situation is for the secondo Edison: it seems to work but after some times it is not recognized.

      It is very strange: they worked fine but after some times they doesn't worked.

      I'm new on Edison and I don't find any document useful for resolve my problem.

      Can someone help me? I use Edison on windows 8.1.

        • 1. Re: Edison in damaged?
          DiegoV_Intel

          Hello GiuseppePegasus,

           

          Let's try to re-flash the Edison modules. There are two methods to flash the Edison:

           

          • Using the Flash Tool Lite: This is the recommended method which uses a software called Flash Tool Lite. You can download it from the following site (under the Flash Tool Lite section): IoT - Intel® Edison Board Download | Intel® Developer Zone. You will find a user's guide as well.
          • Using the flashall script: This is an alternative method. Try this method if the Flash Tool Lite doesn't work.  A guide to perform this method is available in the following document: How to Run the Flashall Script

           

          If none of the methods above work, I recommend you to check the solution provided by another user in this following thread: Can't Flash Edison - USB not recognized. He had the same issue but was able to solve it. For him, the issue was caused by the USB ports. You should use USB 2.0 ports to connect the Edison boards.

           

          Regards,

          Diego.

          • 2. Re: Edison in damaged?
            GiuseppePegasus

            Hi Diego,

             

            thanks for your reply. I uninstalled all driver, software used from Intel Edison. I reinstalled all and Edison was accessible via Putty. With Flash Tool Lite I was able to re-flash the Edison.

            Now Edison is recognized in Manage resources and it is accessible via Putty.

            I activate the wifi but it is not possible to establish a connection in Intel XDK IoT edition. Configuring manually the connection I receive the error:

             

            Error on ssh connection: Error: connect ECONNREFUSED

             

            Why I have this error?

            Thanks.

            Best regards.

            Giuseppe

            • 3. Re: Edison in damaged?
              DiegoV_Intel

              Hello GiuseppePegasus,

               

              Are you using the latest image version? Please post the outcome of the following command:

               

                   configure_edison --version

               

              I could try to reproduce the error you are getting, but let me know first the image version you flashed into your Edison.

               

              Regards,

              Diego.

              • 4. Re: Edison in damaged?
                GiuseppePegasus

                Hi Diego,

                 

                I downloaded the last image version.

                The information you required is:

                root@edison:~# configure_edison --version                                                                                                                                             

                159

                 

                Thanks.

                Best regards.

                Giuseppe

                • 5. Re: Edison in damaged?
                  DiegoV_Intel

                  Hello GiuseppePegasus,

                   

                  When you configured the Edison's Wi-Fi, did you assign a root password? I've gotten SSH connection errors when there is no root password assigned to the Edison, even though the Edison has the Wi-Fi configured.

                   

                  Regards,

                  Diego.

                  • 6. Re: Edison in damaged?
                    GiuseppePegasus

                    Hi,

                     

                    Diego I haven't assigned the root password. Now it works!

                    Thanks for your precious support!

                    Giuseppe