9 Replies Latest reply on Nov 11, 2016 8:05 PM by Viperracing

    Audio resolution problem with HD530 and i5 6600K

    frankpc

      This deals with Intel Display Audio Driver.  If it is in the wrong place, please advise.

       

      I built a HTPC with a Gigabyte Z170X-Gaming 7 motherboard with HD530 and an Intel Skylake i5 6600K cpu.  64-bit.  The motherboard complies with HDMI 2.0 and HDCP 2.2.

       

      I downloaded and installed the newest Intel HD Graphics driver version 15.40.7.4279 (Intel® Iris™, Iris™ Pro, and HD Graphics Production Driver for Windows® 7, 8.1, & 10)

       

      In Advanced Properties under my DENON-HDAVR playback sound device, the '24-bit, 192000 Hz (Studio Quality)' default format did not show up in Windows 8.1, 64-bit Pro.  But it does show up in Windows 7 64-bit Pro.

       

      The Intel HD Graphics zip file contains two folders under the 'DisplayAudio' folder.  One is entitled "6.16" and the other is "8.20".  The 8.20 version is automatically chosen and installed (the Intel Display Audio properties states version 8.20.0.541).  I just discovered that when I force the "6.16" .inf file to install, the missing resolution is listed.  While installing the 6.16 version, an "Update Driver Warning" is displayed stating the driver is not recommended.

       

      I have switched back and forth between the two versions and 8.20 never displays the 24-bit, 192000 Hz resolution and the 6.16 version always does.

       

      Does this indicate a problem with the Intel driver selection process for this motherboard?

       

      As information, I initially installed the drivers that came with the motherboard.  I later updated those drivers with the drivers on the Gigabyte site.  The aforementioned resolution was missing in both cases within Windows 8.1.

       

      Thank you.

        • 1. Re: Audio resolution problem with HD530 and i5 6600K
          allan_intel

          I need you to fill out the following form: Default level information for reporting Graphics issues

          I will try to replicate this issue and update this thread as soon as possible.

           

          Allan.

          • 2. Re: Audio resolution problem with HD530 and i5 6600K
            frankpc

            Category

            Questions

            Answers (N/A if not applicable)

            Description

            Provide a detailed description of the issue

            The 24 bit, 192000 Hz audio resolution is not listed under my AVR HDMI device in Windows 8.1 when the newest audio driver version 8.20.2.541 is used.  However that resolution does show up when I use audio driver version 6.16.0.3180, which seems to be the proper driver for Windows 7.  But I have to force install ver. 6.16.0.3180 and ignore a warning against its installation.

             

            I believe the same issue exists with Windows 10 as it does with Windows 8.1.  But I didn't pursue the issue with Windows 10 sufficiently.  However I could pursue the Windows 10 issue if requested to do so.

             

            When using 64-bit Windows 7 Pro on this same PC, the default HD Audio driver installed is the 6.16.0.3180 and the 24-bit, 192000 audio resolution is present.

            Does it fail every single time, or only sometimes?
            If you can offer a % rate please do.

            Every single time.  I can switch between drivers and the problem always occurs with version 8.20.2.541.

            Hardware (HW)

            Brand and Model of the system.

            Gigabyte z170x-gaming 7 (rev. 1) motherboard.  Skylake i5 6600K processor, 8 GB DDR4 RAM

            Hybrid or switchable graphics system?
            ie Does it have AMD or NV graphics too?

            No. Using integrated HD530 graphics.

            Make and model of any Displays that are used to see the issue (see note2 below).
            LFP
            = Local Flat Panel (Laptop panel)
            EFP = External Flat Panel (Monitor you plug in)

            Denon AVR-x7200 wa receiver (HDMI)

            Sony XBR75X940C television (HDMI)

            How much memory [RAM] in the system (see note2 below).

            8GB

            Provide any other hardware needed to replicate the issue.
            ie: Cables&brand, cable type [vga, hdmi, DP, etc], dock, dongles/adapters, etc

            HDMI cables

            Hardware Stepping (see note1 below).

            PCI\VEN_8086&DEV_1912&SUBSYS_D0001458&REV_06

            PCI\VEN_8086&DEV_1912&SUBSYS_D0001458

            PCI\VEN_8086&DEV_1912&CC_030000

            PCI\VEN_8086&DEV_1912&CC_0300

            Software (SW)

            Operating System version (see note2 below).

            Windows 8.1, 64 bit Pro

            VBIOS (video BIOS) version. This can be found in “information page” of CUI (right click on Desktop and select “Graphics Properties”.

            1028.0

            Graphics Driver version; for both integrated Intel and 3rd party vendors (see note2 below).

            10.18.15.4279

            SW or Apps version used to replicate the issue.

            n/a?

            Configurations

            Single display, clone, or extended (see note2 below).

            Single Display - AVR and TV only

            Display resolution & refresh rate setting of each display (see note2 below).

            1080 x 1920

            AC or DC mode, i.e. is power cable plugged in or not?

            AC

            How to repro

            Please provide steps to replicate the issue.  These steps are very crucial to finding the root cause and fix.
            A screenshot to illustrate the issue is a huge plus. A video of the failure is even better! Attach to the post or provide the YouTube link.

            1. Assumes Intel HD Audio driver 8.20.0.541 is installed.
            2. Power up AVR and TV
            3. Power up PC
              1. Control Panel - Hardware and Sound - Manage Audio Devices - Select the HDMI device (DENON-AVRHD) - Properties - Advanced -
            4. Read the list of resolutions available. 24/192000 not listed.



            ...


             

            Per Note 1:

             

            PCI\VEN_8086&DEV_1912&SUBSYS_D0001458&REV_06

            PCI\VEN_8086&DEV_1912&SUBSYS_D0001458

            PCI\VEN_8086&DEV_1912&CC_030000

            PCI\VEN_8086&DEV_1912&CC_0300

             

             

            Per Note 2:

             

            BaseBoard ManufacturerGigabyte Technology Co., Ltd.
            BIOS ModeUEFI
            BIOS Version/DateAmerican Megatrends Inc. F5p , 10/05/2015
            Embedded Controller Version255.255
            Platform RoleDesktop
            ProcessorIntel(R) Core(TM) i5-6600K CPU @ 3.50GHz , GenuineIntel
            Secure Boot StateNot Available
            SMBIOS Version2.8
            System ManufacturerGigabyte Technology Co., Ltd.
            System ModelZ170x-gaming 7 (rev. 1)
            System SKUUPC 8 89523 00142 4 || EAN 4 719331 829353
            System Typex64-based PC
            • 3. Re: Audio resolution problem with HD530 and i5 6600K
              frankpc

              Thank you Allan.  Please advise if I haven't provided all the information you require.

               

              Thanks for the help!

               

              Frank Chapman

              • 4. Re: Audio resolution problem with HD530 and i5 6600K
                allan_intel

                Thanks for the information. I have escalated this matter to our engineering team. If I need anything else, I will update this thread.

                 

                Allan.

                • 5. Re: Audio resolution problem with HD530 and i5 6600K
                  frankpc

                  Thank you Allan,

                   

                  I just tried two newer drivers.  So if the engineering team wonders whether Intel's most recent drivers work, here are the results:

                   

                  driver 8.20.0.580 had the same problem as 8.20.0.541 mentioned above and is the recommended driver for Windows 8.1 and 10

                   

                  driver 6.16.0.3182 works in Windows 8.1 just as 6.16.0.3180 did, but is most likely for Windows 7.  And it has to be forced to install in Windows 8.1

                  • 6. Re: Audio resolution problem with HD530 and i5 6600K
                    allan_intel

                    Thanks for the information.

                     

                    Allan.

                    • 7. Re: Audio resolution problem with HD530 and i5 6600K
                      dariocs

                      Hello Allan,

                       

                      I can confirm the problem still exists (and it seems to be quite common according to some A/V forums)

                      My machine is a sixth gen. i7 (see details below). Summing up the issue:

                       

                      • With audio driver version 8.20.00.745:
                        • No 24/192 audio output possible through HDMI, neither using DirectSound nor WASAPI
                        • Máximum output seems to be 176 kHz (not sure if 16 bit or 24 bit)
                      • With audio driver version 6.16.00.3190:
                        • 24/192 audio output is OK

                       

                      Thanks for checking this issue again

                       

                       

                      Category

                      Questions

                      Answers (N/A if not applicable)

                      Description

                      Provide a detailed description of the issue

                      Failure to output audio at 24 bit / 192 kHz

                      Does it fail every single time, or only sometimes?
                      If you can offer a % rate please do.

                      Everytime

                      Hardware (HW)

                      Brand and Model of the system.

                      HP 15" Pavillion ak-003 laptop (i7-6700HQ at 2.6 GHz)

                      Hybrid or switchable graphics system?
                      ie Does it have AMD or NV graphics too?

                      Switchable: Intel HD Graphics 530 & Nvidia GeForce 950M GTX. The issue appears no matter the card working.

                      Make and model of any Displays that are used to see the issue (see note2 below).
                      LFP
                      = Local Flat Panel (Laptop panel)
                      EFP = External Flat Panel (Monitor you plug in)

                      Marantz SR6006 A/V receiver & Samsung UE55D6530 digital TV

                      How much memory [RAM] in the system (see note2 below).

                      16 GB

                      Provide any other hardware needed to replicate the issue.
                      ie: Cables&brand, cable type [vga, hdmi, DP, etc], dock, dongles/adapters, etc

                      HDMI 1.4 certified wires

                      Hardware Stepping (see note1 below).

                      PCI\VEN_8086&DEV_191B&SUBSYS_816B103C&REV_06

                      PCI\VEN_8086&DEV_191B&SUBSYS_816B103C

                      PCI\VEN_8086&DEV_191B&CC_030000

                      PCI\VEN_8086&DEV_191B&CC_0300

                      Software (SW)

                      Operating System version (see note2 below).

                      Windows 10 Home 64 bit

                      VBIOS (video BIOS) version. This can be found in “information page” of CUI (right click on Desktop and select “Graphics Properties”.

                      Sorry, unable to find this data where you indicate

                      Graphics Driver version; for both integrated Intel and 3rd party vendors (see note2 below).

                      10.18.15.4248

                      8.20.00.745 (audio)

                      SW or Apps version used to replicate the issue.

                      foobar2000

                      Kodi MediaCenter 15.2

                      Configurations

                      Single display, clone, or extended (see note2 below).

                      Single display: PC --> A/V receiver --> TV (see above)

                      Display resolution & refresh rate setting of each display (see note2 below).

                      1920x1080, 60 Hz, progressive

                      AC or DC mode, i.e. is power cable plugged in or not?

                      AC

                      How to repro

                      Please provide steps to replicate the issue.  These steps are very crucial to finding the root cause and fix.
                      A screenshot to illustrate the issue is a huge plus. A video of the failure is even better! Attach to the post or provide the YouTube link.

                      1. Power up AVR and TV
                      2. Power up PC
                        1. Control Panel - Hardware and Sound - Manage Audio Devices - Select the HDMI device (Marantz-AVR) - Properties - Advanced -
                      3. Read the list of resolutions available. 24/192000 not listed.
                      4. Failure trying to reproduce any 24/192 audio using foobar2000, either throug WASAPI or DirectSound
                      5. 24/192 audio files can be reproduced using Kodi media center. However, output is automatically clipped to 176 kHz

                      ...

                      • 8. Re: Audio resolution problem with HD530 and i5 6600K
                        allan_intel

                        Would you try the following driver?

                         

                        Download Intel® Beta Graphics Driver for Windows* 7/8.1/10 [15.40]

                         

                        Please let me know your findings.

                         

                        Allan.

                        • 9. Re: Audio resolution problem with HD530 and i5 6600K
                          Viperracing

                          I confirm that this problem continues with Intel HD 530 on Intel i5-6600K and i7-6700HQ

                           

                          The new driver

                           

                          Intel® Graphics Driver [15.45]

                          Version: 15.45.10.4542 (Latest) Date: 11/9/2016

                           

                          and old driver

                           

                          Intel® Graphics Driver for Windows® 7/8.1/10* [15.40 6th Gen]

                          Version: 15.40.14.4352 (Latest) Date: 12/23/2015

                           

                          They have the same problem

                           

                          The new version of (Intel screen sound 10.2.0.0.96) does not solve the problem

                           

                          It has been more than a year that intel is aware of this problem and continues without repair its drivers

                           

                          This problem is located on Windows 10 x64 and Windows 8.1 x64

                           

                          The sound can not be heard at more than 48,000 Khz at 16 or 24 bits on my ONKYO TX-NR747 Full firmware update (08-31-2016), and using HDMI 2.0a cables high quality.

                           

                          In windows 7 x64 it works correctly with the driver version 6.16.00.3190 but this version of the driver is not able to work in windows 10 x64 correctly

                           

                          If this community forum can not report this problem to Intel support, I ask that I be given an address or link, where I can inform the Intel technical support department to open an issue, if they are so kind.

                           

                          Thank you very much.