2 Replies Latest reply on Nov 10, 2015 6:18 AM by Folfy

    Mobile Core i7 4700HQ not entering C6 Package state

    GTMoraes

      Hello, this is a Lenovo Y50-70 Touch, with Core i7 4700HQ, Intel HD4600 and GeForce GTX860M.

       

      I've been getting 1:40hrs out of this laptop's battery, while identical models are getting 3 to 3:30 hours. I've pinned it down to the processor consumption, that where identical processors on machines of the same model would consume up to 2W when idle, mine would consume around the triple of this.

       

      I've tried doing many things such as setting up the power profiles, messing with hidden power profile settings, completely reinstalling Windows, running a special software that is able to control the C states (ThrottleStop), among other things, and the processor package still NEVER falls to C6 state.

       

      The CPU passed the Intel Processor Diagnostic Tool, and I've even tried Intel BITS, off Windows, but unfortunately it didn't detect my processor model for some reason, and only displayed generic tests.

      I've also read on the internet that the C6 package state is dependent on the IGP state. My HD4600 seems to be stuck at a minimum of 599MHz. The frequency still goes up when demand arises accordingly, but instead of sitting idle at 350MHz (that's what the ARK says), it sits at 599MHz. Interestingly, the moment I remove the AC cable, the IGP falls briefly to 200MHz, then ramps up to 599MHz, even though the IGP usage is below 1%.

       

      At first, my CPU wasn't even entering Package C3 state, but thanks to ThrottleStop, I was able to use the C7 Interrupt Response Limit and "unlock" the Package C3 state. The estimated power consumption fell greatly, but it is still nowhere near the 1~2W found in identical processors.

       

      Here's a shot of mine, displaying the C states. Note how Package C6 is zeroed

      http://i.imgur.com/oacbOQf.png

       

      Now here's the shot from an identical processor and laptop (Same model, build date, BIOS version, general configuration). Note how, even though the screenshot was taken in less than ideal conditions (not waiting the processor to settle), it displays some Package C6 state

      http://i.imgur.com/nZVQKKw.png

       

      And now here's a similar processor, in an ideal condition

      http://i.imgur.com/91i43Ep.png

       

       

      My best guess is that the IGP is somehow stuck in a powered state, thus the Package can't fall into C6. But I might be wrong (as I've been in many guesses before this), and I'd love to hear suggestions or experiences on this matter.

        • 1. Re: Mobile Core i7 4700HQ not entering C6 Package state
          ivanu_intel

          Hello GTMoraes,

           

          Thank you for joining the Intel communities.

           

          In this case if the Intel® Processor Diagnostic Tool passed then you processor is working fine, I would recommend contacting your system manufacturer for them to guide you how to set up the C- States in the BIOS. Also that you system manufacturer is more familiar how your system has been built and how the components interact with each other.

           

          You can wait to see if somebody else can POST here information about similar problems like this that were already solved and also you can see the C-States and processor TDP at:

          file:///C:/Users/umanamiv/Downloads/4th-gen-core-family-desktop-vol-1-datasheet.pdf

           

          Thanks,

          • 2. Re: Mobile Core i7 4700HQ not entering C6 Package state
            Folfy

            Hello,

             

            I seem to have a quite similar issue with my Acer VN7-592G (i7-4720HQ / GTX960M), running Windows 10 x64.

            So the effects I've noted so far:

            - The Package never enters C6 - still, all cores are 95%+ in C7

            - The MSR 0xE2 is locked via bit 15, and the package c-state limit (bit 2:0) contains the value "5" - I haven't found a proper reference yet, to which c-state that correlates?

            - If I unplug my 2.5k HDMI Monitor from my Notebook, it at least enters C3, otherwise it would only enter C2 (I've heard this seems to be a "feature"?).

            - My IGP-Clock also never falls below 600Mhz, but Graphics are already using zero-power, and forcing it to 200MHz doesn't seem to have a effect on package power either.

            - The package power consumption also seems to be affected by beeing connected to AC, see the perfomance figures I've collected below:

            (All tests were performed with Firefox running in the Background, and using a balanced power profile - the power saver profile brought no major improvement)

             

            StatePackage [W]Core [W]GPU [W]DRAM [W]Package C2 [%]Package C3 [%]
            AC - HDMI Disp.8,50,301,7800
            DC - HDMI Disp.5,80,301,7800
            AC - Internal Disp.6,50,301,42060
            DC - Internal Disp.3,50,201,41070

             

            So there's another 3W decrease in power consumption, when unplugging the power cord!

            There are no differences (even in the hidden settings) of the powerplan, so I wonder which feature could be kicking in right there...

             

            BR

            Fabian