8 Replies Latest reply on Jul 7, 2016 4:55 PM by mikec_intel

    NUC5i7RYH - Microphone Does Not Work

    eezis

      I wrote some code yesterday to record audio files. Got it to work on iMac, android, an iOS. But not in windows. After awhile I realized I had an hardware issue. Tested the code on a different system and it recorded no problem. Started to troubleshoot the microphone on the NUC running Windows 10 and that was the issue. The microphone does not work.


      My system has speakers in the ASUS display, as well as the audio input. I have tried it with the display audio disabled. Still doesn't work. I am using a headset. The headset works perfectly well (as do several others that I tried).


      The input has the RealTek High Definition Audio driver, rtkvhd64.sys, 6.01.7581.


      Capturing audio is critical to my project, need to get this fixed ASAP.


      Device Manager shows the Microphone under "Audio inputs and outputs", everything appears fine, but it will not work.  When I try to record with the mic, the application does seem to access the port, but it captures system noise rather than spoken input. Again, I can take this application, move it to my son's Windows 10 system (not a NUC system) and everything works perfectly.


      Any help appreciated, even if you only confirm that the microphone works on your 5i7RYH kit.