4 Replies Latest reply on Oct 29, 2015 8:57 AM by JPMontero_Intel

    Sometimes 3G USB interface module will be fail in Galileo/Quark.

    clayder

      Hi Intel

       

      We have galileo gen 1 board.  We try to enable 3g module. 

       

      Our 3g module is usb interface.

       

      When the 3G module plug in, the system should be get ttyUSB0/ ttyUSB1/ttyUSB2.


      (1) First step  :   We build the spi code ---> When the 3G module plug in, the system get ttyUSB0/ ttyUSB1/ttyUSB2.    


      (2) Second step :   We try to rebuild spi code again.    --->  When the 3G module plug in, the system just only get ttyUSB0.


      The EDKII_v1.1.0 , spi-flash-tools ,sysimage_v1.1.0  and linux yocto tmp-spi quark code is the same. We don't have any change.


      We just only to rebuild spi code.  Follow yocto BSP 1.1 step by step.



      But sometimes rebuild spi code,   The system can not get ttyUSB 1and ttyUSB2.


      Why the UEFI will be get different result (ttyUSB*)?


      Do you have any advice?  


      Cy

       

       

       

       

       

        • 1. Re: Sometimes 3G USB interface module will be fail in Galileo/Quark.
          JPMontero_Intel

          Hi clayder,

           

          Are you building the default Yocto image? Are you making any changes into the kernel?

           

          Regards,
          JPMontero_Intel

          • 2. Re: Sometimes 3G USB interface module will be fail in Galileo/Quark.
            CMata_Intel

            Hi clayder,

            Do you have updates in this? Have you been able to include the module in the image and use it? Let us know if you are doing other changes in your build

             

            Regards,

            Charlie

            • 3. Re: Sometimes 3G USB interface module will be fail in Galileo/Quark.
              clayder

              Hi Charlie 

              Sorry to late reply. We follow the BSP follow 1.1 document to build SD and SPI.

              Our mass product software version is BSP1.0.4.

               

              We used the U6300 3G module.  

              The U6300 HSUPA PCI Express Mini Card is an embedded module.

              https://www.texim-europe.com/getfile.aspx?id=85374

              When the 3G module plug in, the system shoule be get  ttyUSB0 ,ttyUSB1 and ttyUSB2.

               

               

              [Test step 1]

              After system power on, I just only get ttyUSB0.


              [Test step 2]

              Then I power off and on, system is restart.

              After system power on, I just only get ttyUSB0 again.


              [Test step 3]

              Then I send command "reboot" in debug console.      <--- software reboot

              After system reboot, I get some message about the usb.

              --------------------------------------------------------------------------------------------------

              [   15.126324] usbserial: USB Serial support registered for GSM modem (1-port)

              [   15.214135] usb 2-2: GSM modem (1-port) converter now attached to ttyUSB0

              [   15.366261] usb 2-2: GSM modem (1-port) converter now attached to ttyUSB1

              [   15.516614] usb 2-2: GSM modem (1-port) converter now attached to ttyUSB2

              --------------------------------------------------------------------------------------------------

              I can get ttyUSB0, ttyUSB1 and ttyUSB2. 



              I check the RERST_N (PIN22) about PICE interface is key point.

              When we don't connect RESET_N(PIN22), we can correct get ttyUSB0,ttyUSB1 and ttyUSB2.

              When we do connect RESET_N(PIN22), we just only get ttyUSB0.

              We used Oscilloscope to check Reset single about 1.5sec when system boot up.

              Because capacitance effect I think 1.5sec that is not correct.

               

              Why the bps 1.0.4 is correct get ttyUSB0~2?  

              Do you have any advice?

              • 4. Re: Sometimes 3G USB interface module will be fail in Galileo/Quark.
                JPMontero_Intel

                Hello clayder,

                 

                We are still investigating about your issue. We will let you know once we have more suggestions for this.

                 

                Regards,
                JPMontero_Intel