1 Reply Latest reply on Oct 14, 2015 1:06 PM by ricardog_intel

    SC2 only recognizing HDG 4000. Workaround/solution?

    TheOmegaDuck

      Hi,

       

      I just updated Starcraft 2 to the latest patch, and now it's not recognizing my dedicated graphics card.

       

      I'm running a Dell Inspiron 7520 (Windows 8.1) with an Intel HD Graphics 4000 integrated card, and a dedicated AMD Radeon HD 7730M card. I've set the priority in the catalyst control software to High, I've tried running it in compatibility mode, nothing works. Just tried to disable the Integrated card, and it doesnt work either. It doesnt show up in my BIOS, and when I disabled it using the hardware manager, SC2 tries running it off the processor instead of the dedicated card. Everything is up to date, no missing drivers that I know of.

       

      Suggestions/Workarounds?

        • 1. Re: SC2 only recognizing HDG 4000. Workaround/solution?
          ricardog_intel

          In this case, you need to uninstall the graphic drivers from Intel® and AMD, then restart the laptop, then access the OEM (DELL) website and install the latest drivers, installing first Intel® driver, then restart the laptop and then install the AMD graphic driver then restart again. Using a system with switchable graphics you need to use the drivers provided by the OEM (DELL) they make the drivers to work together, installing the drivers from our website you are installing generic drivers.