8 Replies Latest reply on Jun 10, 2010 4:54 PM by john_s@intel

    Intel SS4200-E: RAID 5 Parameters?


      Hi there!


      I'm trying to recover the data on my RAID 5 that was in my SS4200-E unit.

      I plugged in the 3 working drives to a PC, and ran Runtime Software RAID Reconstructor on it.


      However, I still cannot find the RAID 5 array, and is asking for some RAID 5 parameters:


      Block Size: 4KB?

      Parity Rotation: Foward/Backward/Backward(Dynamic Disk)??

      Start Sectors to probe: (it auto-suggested 7,15)

      Number of Sectors to probe: (it suggested 10000)


      Or does anyone know of another utility that might be able to recover the data from the RAID5 disks?


      Any help is greatly apprecaited!

        • 1. Re: Intel SS4200-E: RAID 5 Parameters?

          I've never tried recovering the drives in a different unit.  What did the SS4200 say when you tried recovering the RAID natively?

          • 2. Re: Intel SS4200-E: RAID 5 Parameters?

            Actually, all 4 drives seems to be OK, but the SS4200 won't mount it ..

            So now I've plugged the 4 drives to my Windows computer and am trying to extract the data before doing anymore troubleshooting on the SS4200 box.


            I've discoverd that the Block Size/Stripe Size/Chunk Size is 32K

            Block Order is "left-asymmetric"

            so the only thing left is "Offset".


            How sectors till the start of the RAID5 data?

            can anyone from Intel chime in?

            • 3. Re: Intel SS4200-E: RAID 5 Parameters?

              Ah, i found the answer to my question.


              It seems that no Windows RAID recovery app can recover a SS4200-E RAID5 because the Windows RAID recovery apps only understand ext3 (and NTFS and FAT, etc), but the SS4200-E uses LVM2 across the array, THEN layer on ext3 on top of that.

              (in contrast to just laying ext3 across the array).


              Seems like this extra LVM2 layer confuses the Windows RAID recovery apps.


              Solution?  Linux boot-CD then try to mount the array again using "mdadm" and LVM2 commands.

              • 4. Re: Intel SS4200-E: RAID 5 Parameters?

                My SS4200E RAID5 (Parity option in webgui data protection) complains in web gui that "Data on your device is unavailable. 4 disk on the device have existing data that will need to be overwritten to re-enable storage.  " then it ask "click here to authorize overwritting existing data" after I accidentally pull the power plug.  It shows the System health "faulted".  How  can I verify if the disks are ok or actually one of the disks went bad.


                I'm able to access ssh in as root, I suspect the power loss caused file system corruption, is there anyway I can check and fix the raid 5?

                • 5. Re: Intel SS4200-E: RAID 5 Parameters?

                  how were you able to read your array data on a linux machine?  what commands did you use?  did you use any particular distribution?


                  i installed my drives onto a Ubuntu 10.04 Desktop machine.  it can see the drives in the Disk Utility but when I go to start it, it says "Not Enough components available to start the RAID Array".  I have all 4 drives installed  what else could I be missing?  the DOM is the only other drive on the Intel SS4200-E.

                  • 6. Re: Intel SS4200-E: RAID 5 Parameters?

                    could you tell me how you were able to mount the array?


                    I installed my drives in a linux pc running Ubuntu 10.04 but when I go to start the array using the GUI Disk Utility, it says "Not Enough Components to Start the RAID Array".


                    I have all 4 drives installed and visible on the machine and they are all healthy.

                    thanks in advance

                    • 7. Re: Intel SS4200-E: RAID 5 Parameters?

                      i figured it out-just installed the lvm2 and dmadm packages and it worked.


                      doesn;t seem to be well known that it seems like the NAS software is running under some form of linuix.  I thought it was windows home server.

                      • 8. Re: Intel SS4200-E: RAID 5 Parameters?



                        That information is available on the SS4200-E suppoer site:



                        By the way, yes, the SS4200-E runs a proprietary Linux kernal for it's operating system. The SS4200-EHW has no operating system and is meant for Windows Home Server installation.