5 Replies Latest reply on Oct 14, 2015 1:47 PM by Intel_Alvarado

    Servo trouble - can't run more than 4.

    Narlo

      Hello to everyone,


      I'm working on rather simple robot project and I got stuck with a problem. I'm using Intel Galileo Gen1. I have six digital servos powered externally (from SMPS). My circuit is definitely good. It runs perfectly from an Arduino Mega. When I run the exact same software on the Galileo Gen 1, the servos goes crazy. By crazy I mean that 4 servos are working fine, 5th is working with little delay compared to the rest, and the last one (6th) isn't moving at all. I've done a lot of research.


      I tried to connect servos to different PWMs pins (I'm using all of them of course, pins 3, 5, 6, 9, 10, 11, but tried to connect them in different combinations). The results are as follows:

      If 4 servos are connected to, for example, pins 3, 9, 10, 11, everything is ok. But if I try to connect another servo to pin 5, servo connected to pin will start to move with a delay. And after another servo being         connected, servo connected to pin 10 will start to move with a delay, and servo connected to pin 11 will stop moving at all.

       

      I know my software is written correctly for Arduino. I know there are differences between the Servo libraries on each (I tried Mikal Hart's servo library, without success). And I know that circuit is fine.

       

      Thank you in advance for your help!