5 Replies Latest reply on Oct 11, 2015 6:02 PM by MarcelG

    Mini Breakout Host Mode

    MarcelG

      I'm having quite a lot of trouble trying to connect a USB audio device to my Edison.

      I have had a good look around the forum and have found many helpful tips. I feel like I have tried them all and still no luck.

       

      I'm using the Mini Breakout Board

      I'm supplying power correctly, 12 volt external power supply to J21.

      OTG adapter is connected to J16

      I have tried multiple OTG adapters: Micro USB Type B to USB A.

      The ID pin (4) is connected to Ground (5).

       

      The output of dmsg shows the ID pin is detected on plugin and removed on remove.

      root@Edison:~# dmesg -c
      [  582.109690] pmic_ccsm pmic_ccsm: USB ID Detected. Notifying OTG driver
      [  667.943987] pmic_ccsm pmic_ccsm: USB ID Removed. Notifying OTG driver
      
      
      

       

      And of course lsusb returns the famous

      root@Edison:~# lsusb
      unable to initialize libusb: -99
      
      
      

       

      Looking at intel_dan's example of how this setup should look I noticed that I've never seen the DS3 LED on when plugging the OTG adapter into J16. Further no power ever goes to the usb device.

      This makes me feel like the USB ID is detected but is never switched to host mode.

       

      I have run into a wall here and need some guidance on where to look next.

       

      Thanks

       

      Note

      I've tried cold booting with it out, plugging it in later. cold booting with it in. warm rebooting (which seems of little point as the device never connects properly)

       

      root@Edison:~# configure_edison --version
      159