1 Reply Latest reply on Nov 30, 2009 8:04 AM by Cpt.Dogfruit

    Intel® Celeron® Processor 900

      Can a -

      Intel® Celeron® Processor 900

      Run these system requirements:

      Processor : Intel Pentium IV at 2.0 Ghz (XP) / Intel Pentium IV at 2.4 Ghz (Vista & 7)