4 Replies Latest reply on Nov 24, 2009 6:21 PM by Wordsend

    Slow Performance on x18 gen 1

    veggiem0nster

      Newegg recently had a sale on DANE-ELEC Intel x18 80GB SSD drives, so i bought two for RAID 0.  I made sure to enable AHCI in my BIOS, installed Windows 7, and found my read & write speed performing very slow (relative to expected performance).

       

      My x18 Raid 0 setup got the following:

      Windows 7 WEI:  7.1 for HDD

      seq Read:  145MB/s  seq Write: 77.02MB/s
      4k Read:  19.77MB/s    4k Write: 30.83MB/s
      Acc Time:  0.107ms      Acc Time: 0.426ms

       

       

      I then reinstalled Windows 7 on a single x18 to see the performance, here's what it got:

      Windows 7 WEI:  7.1 for HDD

      seq Read:  143.76MB/s  seq Write: 60.25MB/s
      4k Read:  16.22MB/s    4k Write: 30.27MB/s
      Acc Time:  0.119ms      Acc Time: 0.100ms

       

      This seems VERY slow for an x18.  I found an old copy of the firmware update tool (8820) and tried to update it, but it said it can't update it because the SSD's have a pre-production firmware (build 0956).  Could this be the reason why they are running so slow??   Anyone know if the firmware that is getting posted by the end of this month will be able to update a pre-production firmware drive?

       

      I was expecting to see my seq reads close to 500MB/s and seq writes at 140MB/s.

       

       

      Here's my system in case that helps:

      OS:  Windows 7

      Processor:  Core i7 860
      Motherboard: Asus Maximus III Formula

      Video:  ATI 5870
      RAM:  gskill 8GB

      HDD:  two intel x18's

        • 1. Re: Slow Performance on x18 gen 1
          veggiem0nster

          btw, here's the link to the drive:

          http://www.newegg.com/Product/Product.aspx?Item=N82E16820157021

           

          They had a promo code which brought them down to $189.99 w/ free shipping.

          • 2. Re: Slow Performance on x18 gen 1
            Wordsend

            I also purchased this same ssd drive packaged by Dane-elec. from Newegg, and my problem is that it locks up often with no activity with AHCI enabled.  (Usually while loading the OS-Vista) I can boot the OS if I change sata ports, but after the subsequent reboot; the problem returns. Is there another way to find my firmware version?

            • 3. Re: Slow Performance on x18 gen 1
              veggiem0nster

              Hey Wordsend, I think your drive is working just fine.  Normally when you enable AHCI, you need to reinstall Windows to allow boot up.... otherwise it'll crash during boot like yours is doing.

               

              There is a way to do this without installing Windows, they describe it here:

              http://forums.pcper.com/showthread.php?t=444831

               

              I'm guessing Windows Vista gave your drive a score of 5.9 since that was the highest at the time?  Would you mind running a benchmark against your drive to see if it's as slow as mine?  Here's the tool I used:  http://www.alex-is.de/PHP/fusion/downloads.php?cat_id=4

              • 4. Re: Slow Performance on x18 gen 1
                Wordsend

                Actually I migrated a working load of Vista from an 80GB sata drive to the ssd with the Acronis migrator that came along with the drive's enclosure package. I currently have a 5.7 WEI score on the sata drive, but could not run this again after installing the ssd because it locked up completely after a couple of minutes.  I actually did get it to boot and run for several hours when I changed sata ports until a power loss. After that the OS would boot no more.

                I also should have mentioned that I only tried enabling AHCI after I had imaged the original "non-ssd" drive and had the lockup problems.  Originally the bios was set to nvidia nforce sata controller enabled, and the Jmicron controller was disabled. Mine is a simple configuration.  In hindsight I see that simply imaging the drive was a mistake, and I should try a fresh load.  Hopefully with the 8820 firmware already on this drive I will not have a problem loading Windows Vista, or 7 from a fresh install, but after what I've read so far I doubt it.